The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail Queue Issue

Discussion in 'E-mail Discussions' started by zigzam, Jul 18, 2005.

  1. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    Currently it seems as though a spammer is send emails though my system or to my system. I get around 250 messages to my mail queue a day that are all spam. I know its not a lot yet, but I would like to stop this before it gets out of hand.

    I have catchall set to fail in whm.

    I have max checks to 60

    I have it set so accounts over quota mail gets deleted.

    Mail Queue deletes after 2 days.

    How can I set it so the server doesnt send messages back to the spammer when emails fail?
     
  2. rfrench10

    rfrench10 Well-Known Member

    Joined:
    Feb 19, 2004
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    New York
    When set to :fail: you WILL send a failure email back to the source.

    Set it to :blackhole: and it just "dissapears" without sending emails.

    :D
     
  3. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    I had it set to blackhole for awhile and it still was filling the queue.
     
  4. rfrench10

    rfrench10 Well-Known Member

    Joined:
    Feb 19, 2004
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    New York
    Make sure you use ":blackhole:" - without the quotes BUT with the beginning and ending colons.

    Good Luck,
     
  5. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    Cant I just select it from the whm options?
     
  6. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    No. That only affects NEW accounts, not existing.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Nope, that is wrong. :fail: does not send a failure back at all and :blackhole: is a very bad idea. More information here:
    http://www.configserver.com/free/fail.html
     
  8. rfrench10

    rfrench10 Well-Known Member

    Joined:
    Feb 19, 2004
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    New York
    Thanks for the correction and the work in investigating and testing this difference. I better change my :blackhole: settings to :fail: right away. I stand corrected.
     
  9. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    I used some code I found on here to set all accounts to fail and the mail queue still fills.
     
  10. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Are the messages being sent out through your server or are the messages being sent to your server? In either case you should look at the messages and the message headers and try to determine what is causing them to stay on the queue. If spammers are sending out messages to non-existant e-mail accounts or non-existant domains this can cause the messages to stay in the mail queue and attempt delivery later. If the messages are staying in the queue because they cannot be delivered to your users (quota, inbox permission issues) those issues will need to be resolved.
     
  11. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    They are from spammers getting sent to non existant emails.
     
  12. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    Then you must not have fail set. If set to fail - they never make it to your queue.
     
    #12 lloyd_tennison, Jul 20, 2005
    Last edited: Jul 21, 2005
  13. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    What command would I use to set all urls to fail?
     
  14. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
Loading...

Share This Page