The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

(Mail Queue) Mail delivery failed: returning message to sender

Discussion in 'E-mail Discussions' started by soundeluxe, Jul 15, 2014.

  1. soundeluxe

    soundeluxe Member

    Joined:
    Jul 15, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, i'm new with cPanel.

    So, yesterday, we moved new server. Now, when i checked Mail Queue Manager, i see too many mail, i made try delete, but today, i receive too much again. I Think its about for "Cron" You can see photo;


    vdserrror1.jpg

    And this is my e-mail on queue.

    Code:
    This message was created automatically by mail delivery software.
    
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:
    
      root@sunucu.domain.net
        The mail server could not deliver mail to root@sunucu.domain.net.  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
    
    ------ This is a copy of the message, including all the headers. ------
    
    Return-path: <root@sunucu.domain.net>
    Received: from root by sunucu.domain.net with local (Exim 4.82)
    	(envelope-from <root@sunucu.domain.net>)
    	id 1X6wKL-0006HP-BF
    	for root@sunucu.domain.net; Tue, 15 Jul 2014 09:35:01 +0300
    From: root@sunucu.domain.net (Cron Daemon)
    To: root@sunucu.domain.net
    Subject: Cron <root@sunucu> root    sh -c "sync; echo 3 > /proc/sys/vm/drop_caches"
    Content-Type: text/plain; charset=UTF-8
    Auto-Submitted: auto-generated
    X-Cron-Env: <LANG=en_US.UTF-8>
    X-Cron-Env: <SHELL=/bin/sh>
    X-Cron-Env: <HOME=/root>
    X-Cron-Env: <PATH=/usr/bin:/bin>
    X-Cron-Env: <LOGNAME=root>
    X-Cron-Env: <USER=root>
    Message-Id: <E1X6wKL-0006HP-BF@sunucu.domain.net>
    Date: Tue, 15 Jul 2014 09:35:01 +0300
    
    /bin/sh: root: command not found
    
    How can i fix this problem?
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Can you paste a copy of your root crontab please
     
  3. soundeluxe

    soundeluxe Member

    Joined:
    Jul 15, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Dear @vanessa, thank you very much for your answer, can you tell me, how can i copy root crontab?
     
  4. soundeluxe

    soundeluxe Member

    Joined:
    Jul 15, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Oh, ok, i've found, i'm on putty now and i've put "crontab -e", i think this is;

    Code:
    0 6 * * * /usr/local/cpanel/scripts/exim_tidydb > /dev/null 2>&1
    35 * * * * /usr/bin/test -x /usr/local/cpanel/bin/tail-check && /usr/local/cpanel/bin/tail-check
    45 */4 * * * /usr/bin/test -x /usr/local/cpanel/scripts/update_mailman_cache && /usr/local/cpanel/scripts/update_mailman_cache
    30 */4 * * * /usr/bin/test -x /usr/local/cpanel/scripts/update_db_cache && /usr/local/cpanel/scripts/update_db_cache
    45 */8 * * * /usr/bin/test -x /usr/local/cpanel/bin/optimizefs && /usr/local/cpanel/bin/optimizefs
    30 */2 * * * /usr/local/cpanel/bin/mysqluserstore >/dev/null 2>&1
    15 */2 * * * /usr/local/cpanel/bin/dbindex >/dev/null 2>&1
    15 */6 * * * /usr/local/cpanel/scripts/recoverymgmt >/dev/null 2>&1
    */5 * * * * /usr/local/cpanel/bin/dcpumon >/dev/null 2>&1
    29 0 * * * /usr/local/cpanel/whostmgr/docroot/cgi/cpaddons_report.pl --notify
    7,22,37,52 * * * * /usr/local/cpanel/whostmgr/bin/dnsqueue > /dev/null 2>&1
    15 */6 * * * /usr/local/cpanel/scripts/autorepair recoverymgmt >/dev/null 2>&1
    30 5 * * * /usr/local/cpanel/scripts/optimize_eximstats > /dev/null 2>&1
    */5 *   * * *   root    sh -c "sync; echo 3 > /proc/sys/vm/drop_caches"
    0 4 * * * /usr/local/cpanel/scripts/upcp --cron
    0 7 * * * /usr/local/cpanel/scripts/cpbackup
    2,58 * * * * /usr/local/bandmin/bandmin
    0 0 * * * /usr/local/bandmin/ipaddrmap
    0 2 * * * /usr/local/cpanel/bin/backup
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The subject of the bounced email you provided shows:

    This matches with the following cron job you have enabled:

    Did you setup this cron job on your own? It's not a standard cron job included with cPanel.

    Thank you.
     
  6. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    You need to remove the user section of the cron job, because the user is already implied by the fact that its in the root crontab. It should look like this:


    Code:
    */5 * * * *  sh -c "sync; echo 3 > /proc/sys/vm/drop_caches"
    
     
  7. soundeluxe

    soundeluxe Member

    Joined:
    Jul 15, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Dear @cPanelMichael, actually, i did not setup this cron, just my old server same use cpanel, my datacenter just make migrate old server to new server, they are setup first cpanel, after they are migrate. How can i fix it? I'm really still really new on cPanel :)

     
  8. soundeluxe

    soundeluxe Member

    Joined:
    Jul 15, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Dear @vanessa, thank you very much again, how can i delete this one? After delete is that return everything normal? If i delete this one, fix it?

     
  9. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Simply edit the crontab (crontab -e) and remove the line.

    This will stop the error from occurring and stop related emails from being sent to you.
     
  10. soundeluxe

    soundeluxe Member

    Joined:
    Jul 15, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you very much, i've deleted that line but i'm still gettin error, what happened i dont understand. Now, i see on queue manager too much that mail;

    Code:
    This message was created automatically by mail delivery software.
    
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:
    
      [email]root@sunucu.dijitalada.net[/email]
        The mail server could not deliver mail to [email]root@sunucu.dijitalada.net[/email].  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
    
    ------ This is a copy of the message, including all the headers. ------
    
    Return-path: <root@sunucu.dijitalada.net>
    Received: from root by sunucu.dijitalada.net with local (Exim 4.82)
    	(envelope-from <root@sunucu.dijitalada.net>)
    	id 1X7gIM-0000bG-Ig
    	for [email]root@sunucu.dijitalada.net[/email]; Thu, 17 Jul 2014 10:40:03 +0300
    From: [email]root@sunucu.dijitalada.net[/email] (Cron Daemon)
    To: [email]root@sunucu.dijitalada.net[/email]
    Subject: Cron <root@sunucu> /usr/local/cpanel/bin/dcpumon >/dev/null 2>&1
    Content-Type: text/plain; charset=UTF-8
    Auto-Submitted: auto-generated
    X-Cron-Env: <LANG=en_US.UTF-8>
    X-Cron-Env: <SHELL=/bin/sh>
    X-Cron-Env: <HOME=/root>
    X-Cron-Env: <PATH=/usr/bin:/bin>
    X-Cron-Env: <LOGNAME=root>
    X-Cron-Env: <USER=root>
    Message-Id: <E1X7gIM-0000bG-Ig@sunucu.dijitalada.net>
    Date: Thu, 17 Jul 2014 10:40:02 +0300
    
    /bin/sh: 1
    : ambiguous redirect
    And its my new cron file;

    Code:
    0 6 * * * /usr/local/cpanel/scripts/exim_tidydb > /dev/null 2>&1
    35 * * * * /usr/bin/test -x /usr/local/cpanel/bin/tail-check && /usr/local/cpanel/bin/tail-check
    45 */4 * * * /usr/bin/test -x /usr/local/cpanel/scripts/update_mailman_cache && /usr/local/cpanel/scripts/update_mailman_cache
    30 */4 * * * /usr/bin/test -x /usr/local/cpanel/scripts/update_db_cache && /usr/local/cpanel/scripts/update_db_cache
    45 */8 * * * /usr/bin/test -x /usr/local/cpanel/bin/optimizefs && /usr/local/cpanel/bin/optimizefs
    30 */2 * * * /usr/local/cpanel/bin/mysqluserstore >/dev/null 2>&1
    15 */2 * * * /usr/local/cpanel/bin/dbindex >/dev/null 2>&1
    15 */6 * * * /usr/local/cpanel/scripts/recoverymgmt >/dev/null 2>&1
    */5 * * * * /usr/local/cpanel/bin/dcpumon >/dev/null 2>&1
    29 0 * * * /usr/local/cpanel/whostmgr/docroot/cgi/cpaddons_report.pl --notify
    7,22,37,52 * * * * /usr/local/cpanel/whostmgr/bin/dnsqueue > /dev/null 2>&1
    15 */6 * * * /usr/local/cpanel/scripts/autorepair recoverymgmt >/dev/null 2>&1
    30 5 * * * /usr/local/cpanel/scripts/optimize_eximstats > /dev/null 2>&1
    0 4 * * * /usr/local/cpanel/scripts/upcp --cron
    0 7 * * * /usr/local/cpanel/scripts/cpbackup
    2,58 * * * * /usr/local/bandmin/bandmin
    0 0 * * * /usr/local/bandmin/ipaddrmap
    0 2 * * * /usr/local/cpanel/bin/backup
     
  11. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    You left something in place, as it clearly shows in the bounce message:

    Code:
    /bin/sh: 1
    
    Make sure you restart crond. Using the 'crontab -r' command usually reloads it but maybe there was an error.
     

Share This Page