Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Mail Queue Manager Exim problem

Discussion in 'E-mail Discussion' started by sassou2009, Mar 14, 2011.

  1. sassou2009

    sassou2009 Active Member

    Joined:
    May 25, 2009
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    51
    hey,
    i'm having a problem sending messages using webmail and php script (wordpress)

    all emails stuck in the mail queue manager:
    Mail Queue Manager
    Code:
    Delivery attempt for Message ID 1PzIJm-0003rl-Ak
    Message 1PzIJm-0003rl-Ak is not frozen LOG: MAIN cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1PzIJm-0003rl-Ak delivering 1PzIJm-0003rl-Ak LOG: MAIN PANIC == Joehon@ymail.com R=lookuphost T=remote_smtp defer (-1): failed to expand "interface" option for remote_smtp transport: failed to open /etc/mailips for linear search: Permission denied (euid=47 egid=12) 
    please Help :confused:
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    The error message indicates the file having the issue:

    Check /etc/mailips permissions:

    Code:
    ls -lah /etc/mailips
    It should show the following:

    Code:
    # ls -lah /etc/mailips
    -rw-r----- 1 root mail 0 Mar 11 21:40 /etc/mailips
    If it does not show root:mail for ownership, then fix that:

    Code:
    chown root:mail /etc/mailips
    If it doesn't show 640 for file permissions, fix that:

    Code:
    chmod 640 /etc/mailips
    If it does have the right ownership and permissions, then next check the file isn't set to be immutable:

    Code:
    lsattr /etc/mailips
    It might look like the following:

    Code:
    # lsattr /etc/mailips
    -------A----- /etc/mailips
    An uppercase A is fine. If it has a lowercase i or a lowercase a, then it isn't fine, and those need removed:

    Code:
    chattr -ia /etc/mailips
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sassou2009

    sassou2009 Active Member

    Joined:
    May 25, 2009
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    51
    thank you very much it works now but i'm getting this error on local emails:

    == root@server1.domain.com R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    That error is only for emails to the root user. Are any emails you send normally actually not working, because that email doesn't impact sending and receiving from normal email users. It's only the root user that is on the never users list and the root user shouldn't be sending and receiving emails normally.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    941
    Likes Received:
    0
    Trophy Points:
    66
    i am also having the same issue
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    There were two issues discussed in this thread. Please provide more details.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    168
    I'm encountering the same issue as described by the OP.

    Code:
    2011-06-23 11:00:43 REDACTED == REDACTED@DOMAIN.COM R=lookuphost T=remote_smtp defer (-1): failed to expand "interface" option for remote_smtp transport: failed to open /etc/mailips for linear search: Permission denied (euid=47 egid=12)
    
    I'm noticing this error when attempting to send mail through the PHP mail() function through jailshell. Permissions on /etc/mailips are correct.

    I've reproduced this behavior on four separate servers.
     
  8. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    168
    The permissions are not the same when viewed through jailshell:

    Code:
    root@server [~]# su testuser
    testuser@testuser.net [~]# whoami
    testuser
    testuser@testuser.net [~]# echo $SHELL
    /usr/local/cpanel/bin/jailshell
    testuser@testuser.net [~]# ls -l /etc/mailips
    -rw-r----- 1 root root 4516 Jun 23 10:58 /etc/mailips
    testuser@testuser.net [~]# exit
    exit
    root@server [~]# whoami
    root
    root@server [~]# ls -l /etc/mailips
    -rw-r----- 1 root mail 4516 Jun 23 00:09 /etc/mailips
    
     
  9. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    168
    I opened a ticket on this and received the following reply:

     
  10. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    This isn't technically the same issue as the original poster who was using webmail and WordPress, since those are not jailed shell command line attempts to send mail.

    Basically in jailed shell, you have /home/username/virtfs setup as the location for hardlinked files. If you go to /home/testuser/virtfs/etc and list the mailips file, it does have a different date and ownership than the /etc/mailips file. You cannot send emails using PHP mail() function in a jailed shell environment of this nature. You will need to either make this user a non-jailed shell user (regular shell) or send the emails normally using the account (Webmail, email client, PHP mail() function in a script like WordPress) without being in jailed shell command line.

    Edit: I didn't realize a reply had already been provided via a ticket as a ticket wasn't mentioned until after I had typed out and posted my reply.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    168
    Thanks, Tristan. Not to hijack the OP's thread, but another option might be to use the PEAR Mail package and authenticate to the SMTP server directly. Though, I haven't tested this.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice