Mail Queue Not Cooperating with Exim Config

sexshun

Active Member
Sep 28, 2005
26
0
151
So I changed these options in the Exim Configuration Editor so my mail queues are more agressive at deleting unreachable mailhosts.

I am overriding the following values
Code:
auto_thaw = 1h
ignore_bounce_errors_after = 1h
timeout_frozen_after = 2h
Yet, when I look at my mail queue, i see a few frozen/stuck emails that have been there for over 14 hours. Any ideas on what I did wrong?
 

jackie46

BANNED
Jul 25, 2005
536
0
166
I have the same problem;

timeout_frozen_after = 2d
ignore_bounce_errors_after = 12h
auto_thaw = 3h

And this does not work. Nothing is auto thawed after 3hrs not to mention the other 2 that dont work.
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
sexshun said:
So I changed these options in the Exim Configuration Editor so my mail queues are more agressive at deleting unreachable mailhosts.

I am overriding the following values
Code:
auto_thaw = 1h
ignore_bounce_errors_after = 1h
timeout_frozen_after = 2h
Yet, when I look at my mail queue, i see a few frozen/stuck emails that have been there for over 14 hours. Any ideas on what I did wrong?
That's an extremely bad idea. So long as you're happy that some email will never get delivered, then go ahead, but otherwise there should be no reason to mess around with the standard queue parameters if you have your email setup correctly (i.e. don't accept email for mailboxes over their quota, don't use catchall aliases, and never use :blackhole:).