The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail quota is full and new incoming mails are queued

Discussion in 'E-mail Discussions' started by nanook, Aug 7, 2008.

  1. nanook

    nanook Registered

    Joined:
    Jun 14, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    One of my clients receive lots of mails for invalid users. He insists to keep catchall working and pointing to an mail account (invalid@hesdomain) that is limited to 20MBs. So this is what happening:

    hundred of trashmail comes to invalid@hesdomain and his quota becomes full in no time. Once the quota is full the new trashmail is queued, making exim queue reach about 25,000 emails waiting for delivery.

    Theres someway to just do not accept new mail ou drop it to /dev/null when mail quota is full?

    He is a VIP Client and just dont wants to make any changes on his domain/account configs.
     
  2. nanook

    nanook Registered

    Joined:
    Jun 14, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ops, another problem:

    When he receives a trashmail and his mail quota is full exim bounces the "mail quota is full" back to the trashmail sender, that does not exist, and the bounces are queued for somedays.

    How do I solve my queue problem?
     
  3. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    you have an option to discard mails for over quota users at Exim configuration editor.
    check the box which says "Reject mail for users over quota at SMTP time. (CPU Expensive)"
     
  4. pirrup

    pirrup Well-Known Member

    Joined:
    Nov 27, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    What you also can do is tweak exim ,

    open exim advanced editor then go to begin retry box and add this :

    * quota

    what it will do is check the quota and send the sender a msg that the mail can't be delivered and discard the message.

    Best regards,

    pirrup
     
  5. FreedomBI

    FreedomBI Well-Known Member

    Joined:
    Jul 7, 2008
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    To be more accurate, it is rejection, not discard or bounce. This means that it is up to the sending mail server to provide a bounce to the user. If it's a legitimate sender, they will receive a bounce. If it is not, then the "sending mail server" is probably a zombie that won't generate a bounce. And if it is spam from a real mail server, then that server is the one generating bounces and getting blacklisted, not yours.

    "Reject mail for users over quota at SMTP time" is by far the friendliest option.

    This ignores the fact that catch-alls are generally a bad idea, for exactly the reasons seen here. If he's worried about messages not getting through because someone mis-typed an email address, any legitimate sender will receive a notification about that.
     
  6. dlennon

    dlennon Member
    PartnerNOC

    Joined:
    May 17, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    pertaining to CPU expensive... how expensive is expensive... my server currently hovers around .60 to 1.19.. Should I consider enabling this.. I am defiantly sick and tired of having 8k messages destine for users on my box where their mailbox is over quota.
     
  7. sneakert

    sneakert Member

    Joined:
    May 5, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    setting not working?

    I enabled this option in the control panel, but mails still seem to be queued.
    Created an account, sent 15 MB worth of mail to it, and then lowered the quota to 10 to make sure it's over quota.

    However, mail is still accepted at the smtp time, and then bounced, which of course fills up the queue quite rapidly.

    Is there another setting that needs to be enabled for this option to actually work, or is there a way to check if the setting is propagated to the exim configuration?
     
  8. Paul Schmidt

    Paul Schmidt Registered

    Joined:
    Mar 15, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Reject mail for users over quota at SMTP time. (CPU Expensive)

    We have used this option and did not notice a load increase. I was concerned about doing it, but it seems to work well.

    Then, the next thing is to delete frozen messages or ones with no return address. These are spam messages and can be deleted. Google "crontab exim frozen" for some suggestions on how to set this up.
     
  9. sneakert

    sneakert Member

    Joined:
    May 5, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Anyone? :)
     
Loading...

Share This Page