The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail Sending Problem..

Discussion in 'E-mail Discussions' started by kamals, Nov 1, 2004.

Thread Status:
Not open for further replies.
  1. kamals

    kamals Member

    Joined:
    Oct 27, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    i recently fixed the dns problem and it seems the website working but when i try to send mails out..i get this error with return mail. is there way to fix this? please let me know..i am a newbie


    550-permitted to relay through this server. Perhaps you have not logged into
    550-the pop/imap server in the last 30 minutes or do not have SMTP
    550 Authentication turned on in your email client.

    the following will show u the dns report..let me know if i did something wrong there?

    http://www.dnsreport.com/tools/dnsreport.ch?domain=newindianfilms.com


    thank you
     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You need to have reverse dns setup for your mail server. Ask your provider to configure.
     
  3. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hi,
    Run these scripts

    /scripts/updatenow
    /scripts/mailperm
    May be it will solve your problem.
     
  4. kamals

    kamals Member

    Joined:
    Oct 27, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    how to run those scripts? in whm/ssh? our provider wouldnt help because its unmanged server..so i gotta do all..could someone explain to me abt configuring it?
     
  5. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Run them using SSH access.
     
  6. kamals

    kamals Member

    Joined:
    Oct 27, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    what command is to make it run? sorry i am a newbie
     
  7. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Just like bijo suggested. Type each one from the prompt and hit enter.
     
  8. kamals

    kamals Member

    Joined:
    Oct 27, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    i ran those scripts, but i am still getting the same error..could someone please help me on this?


    "550-currently not permitted to relay through this server. Perhaps
    you have
    not 550-logged into the pop/imap server in the last 30 minutes or do
    not
    have SMTP 550 Authentication turned on in your email client."
     
  9. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    run:

    /scripts/fixrelayd

    that might help.
     
  10. kamals

    kamals Member

    Joined:
    Oct 27, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    still doesnt work..any other suggestion? when i try to do reverse dns named fail to start..someone pls help

    :(
     
  11. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What do you mean by this?
     
  12. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    There are two possibilities:

    1. Whatever email client you use on your local computer needs to have "My server requires Authentication" enabled and use the same username and password as your incoming email.

    2. Your ISP is blocking Port 25 and does not let you send email via your own server.
    To get around this log onto WHM and under "Service manager" enable Exim on another port like 1352.

    Now in your local email client go to the advanced settings and change the SMTP Port from 25 to 1352.

    This should work.
     
  13. kamals

    kamals Member

    Joined:
    Oct 27, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    when i try to edit the named.conf the way it says in this forum guide for setting up reverse dns.

    named has failed, please contact the sysadmin (result was "named is not running"). Nov 5 14:30:30 13833 named: named shutdown failed Nov 5 14:30:30 13833 named[20109]: starting BIND 9.2.1 -u named Nov 5 14:30:30 13833 named[20109]: using 1 CPU Nov 5 14:30:30 13833 named: named startup succeeded Nov 5 14:30:30 13833 named[20111]: loading configuration from '/etc/named.conf' Nov 5 14:30:30 13833 named[20111]: /etc/named.conf:51: syntax error near '}' Nov 5 14:30:30 13833 named[20111]: loading configuration: unexpected token Nov 5 14:30:30 13833 named[20111]: exiting (due to fatal error)


    this is what i put..anything wrong in it? if i remove this then it works fine..

    };

    zone "138.53.208.in-addr.arpa" IN {
    type master;
    file "/var/named/138.53.208.db";
    allow-update { none; };
    };

    someone please help, i really need this so i can send mails, btw all mails are being returned from anything not only client.like hotmail
     
  14. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Has your provider/NOC confirmed that setting reverse dns is actually delegated to their customers? Not usually the case.
     
  15. kamals

    kamals Member

    Joined:
    Oct 27, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    ok finally the NOC setuped the reverse dns but i am still getting same error when i try to send mails to domains on the server..i am really tired of this.. all seems setuped fine but still saying same error..

    <sales@newindianfilms.com>: host newindianfilms.com[208.53.138.33] said:
    550-sitemail3.everyone.net (omta06.mta.everyone.net) [216.200.145.37]
    is
    550-currently not permitted to relay through this server. Perhaps
    you have
    not 550-logged into the pop/imap server in the last 30 minutes or do
    not
    have SMTP 550 Authentication turned on in your email client.

    take a look at the dns enteries here http://www.dnsreport.com/tools/dnsreport.ch?domain=newindianfilms.com

    anything else should i do to get it running?please help :confused:
     
  16. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    can you check your PM please.
     
  17. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Your dns report looks good now. Have you followed what ccccanada suggested above?
     
  18. greaselove

    greaselove Member

    Joined:
    Aug 7, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I am getting the same error for a user of mine and I know for a fact that it is neither of the above possibilities. There must be more than two. I created the users account on my home machine and when I try to send mail to it, get the same error. All other accounts on the server function normally. Even mail for an addon domain in the users's account works! It's just his primary domain that returns this error over and over. Any more suggestions?
     
  19. Godcore

    Godcore Active Member

    Joined:
    Dec 31, 2002
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    I am having the same problem after restoring a system (we were hacked yesterday).

    One account on the server, with a dedicated IP, cannot send or receive email.

    If I send to one of their accounts, I get a bounce with this error:

    user@domain.com
    SMTP error from remote mailer after RCPT TO:<user@domain.com>:
    host domain.com [69.50.209.196]: 550-ns3.godcore.com [69.50.209.193] is currently not permitted to relay through
    550-this server. Perhaps you have not logged into the pop/imap server in the
    550-last 30 minutes or do not have SMTP Authentication turned on in your email
    550 client.

    This happens regardless of what server / program I use to send email to an account.
     
  20. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    the domain dosent seem to have an entry at localdomains.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page