The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail sent multiple times

Discussion in 'E-mail Discussions' started by pdstein, Jun 28, 2005.

  1. pdstein

    pdstein Active Member

    Joined:
    Apr 14, 2005
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    6
    Every once in a while when I send an email from Outlook, the message gets sent multple times. It only seems to happen when there are large attachments (greater than 1 MB) but not every time large attachments are sent. The number of copies varies - I've seen 12 copies once and 5 copies once. When checking the exim_mainlog, there are entries for each copy of the message sent and their generally spaced about 2 minutes apart. That would seem to indicate that Outlook is resending the message. Maybe Outlook is not getting a "success" message back from the server?

    Has anyone ever experienced or even heard of this problem before?

    Is there anything I can do to prevent it?

    Is there a setting in Outlook that can be turned off so it won't automatically resend on a failure?

    Thanks for your help,
    Paul
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Not something I've seen before. When it happens, have you checked your exim mainlog to see what the SMTP server appears to be doing when multiple deliveries are made. It does rather sounds more like an Outlook issue than an exim one.
     
  3. pdstein

    pdstein Active Member

    Joined:
    Apr 14, 2005
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    6
    I'm really not sure what to look for in the exim_mainlog other than for individual entries for each message sent. Here are 3 of the entries from the first time I'm aware the problem occurred. For privacy reasons, I've replaced the username, domain, and IP of the destination email account with to_user, to_domain, and to_IP:

    2005-05-26 15:30:56 1DbO2D-0003dH-W0 => to_user@to_domain.com R=lookuphost T=remote_smtp H=smtp.to_domain.com [to_IP]
    2005-05-26 15:32:35 1DbO3t-0003mn-Ey => to_user@to_domain.com R=lookuphost T=remote_smtp H=smtp.to_domain.com [to_IP]
    2005-05-26 15:34:14 1DbO5u-00043u-19 => to_user@to_domain.com R=lookuphost T=remote_smtp H=smtp.to_domain.com [to_IP]

    Does that tell you anything?

    - Paul
     
    #3 pdstein, Jun 28, 2005
    Last edited: Jun 28, 2005
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Since each entry has a different message ID it is suggests that Exim is dealing with a different copy each time. This could only really happen if Outlook is sending the same message more than once.
     
  5. pdstein

    pdstein Active Member

    Joined:
    Apr 14, 2005
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    6
    That's the conclusion I came to as well. So, now the question is what possible explanation could there be for Outlook sending the message multiple times?

    It was suggested to me that perhaps the connection to the server was being interrupted before the full message was delivered to the SMTP server and as a result exim was sending only part of the message each time and Outlook, recognizing the interruption, was resending. However, the attachment is the same size and opens correctly in each copy.
     
Loading...

Share This Page