The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail server gave up working after server reboot

Discussion in 'E-mail Discussions' started by Israel_Paya, Jul 16, 2016.

  1. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    32
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Today my server went down. I rebooted it and now all websites work fine but the mail server has given up working. Webmail works actually, but customers cannot receive or send emails from their Outlook, Macs etc.

    How can I solve this problem. It is very urgent. I have more than 100 customers and all of them are calling me.

    Thank you so much in advance.
     
  2. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    32
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Now I want to enter WHM through the link server1.example.com:2087 and says that the DNS address of the server server1.example.com cannot be found.
     
    #2 Israel_Paya, Jul 16, 2016
    Last edited by a moderator: Jul 18, 2016
  3. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Can you login using ssh to run some checks?
     
  4. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    32
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Yes, I can.

    When I try to send a message from Mail in Mac, for instance, it says that the server server1.example.com cannot be found. If you make a ping on server1.example.com it does not respond. So, I think it must be a DNS problem. I'm not sure because I am not an expert.
     
    #4 Israel_Paya, Jul 16, 2016
    Last edited by a moderator: Jul 18, 2016
  5. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    So check what services are running like:
    #service named status
    Read the last few lines of the error log:
    tail 150 /var/log/messages
     
  6. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    32
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    How shall I do that, please? Sorry, but I don't know much of servers. Thank you so much.
     
  7. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
  8. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    334
    Likes Received:
    25
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Your websites are working fine it means the DNS service is running.

    You are facing problem to access WHM using hostname. I think there is issue with hostname.

    First you can check your current hostname which is set on the serve.
     
  9. ssfred

    ssfred Well-Known Member

    Joined:
    Jan 6, 2012
    Messages:
    62
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello

    Check and ensure that the DNS record for the hostname server1.example.com exists in the zone file of example.com . You can check the DNS health of the domain using the URL intodns.com/.

    Mail delivery issue can be due to multiple reasons. Check the mail log /var/log/exim_mainlog for any mail delivery issues.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    You can try running the following command to rebuild the DNS configuration file:

    Code:
    /scripts/rebuilddnsconfig
    Also, do you have a firewall management utility such as CSF installed on the system? If not, you may want to consider installing a utility such as CSF to ensure your firewall rules are properly managed:

    ConfigServer Security & Firewall

    Thank you.
     
Loading...

Share This Page