The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail SNI is enabled, but server certificate is used

Discussion in 'E-mail Discussions' started by mike817, May 31, 2016.

Tags:
  1. mike817

    mike817 Member

    Joined:
    Aug 5, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I have mail SNI enabled for my domain, but when I enter the settings into a mail client, the server certificate is pulled instead of the domain. Is this correct? From the documentation, I thought SNI would use the cert installed for the domain.
     
  2. webhostuk

    webhostuk Well-Known Member

    Joined:
    Sep 11, 2013
    Messages:
    54
    Likes Received:
    6
    Trophy Points:
    8
    cPanel Access Level:
    Website Owner
    I feel its because the server is using the main Server shared IP that's the reason its pulling the server certificate and not the dedicated IP of your domain to send the emails.
     
  3. Kevzon

    Kevzon Member

    Joined:
    Jun 1, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Africa
    cPanel Access Level:
    Root Administrator
    How did you install the certificate and what type of certificate do you have ? (do you have WHM?)
     
  4. mike817

    mike817 Member

    Joined:
    Aug 5, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    After some experimenting, it looks like the certificate is correct only when just the main domain is used in the email settings. So domain.com gets the correct certificate, while imap.domain.com gets the server one. Is that the correct implementation?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    649
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    We have an internal case open to ensure the host used for "Mail SNI" purposes is displayed and integrated with the "Set Up Mail Client" option under "Email Accounts" in cPanel. Thus, if you installed a SSL certificate for "domain.com", and "Mail SNI" is enabled, then "domain.com" will display under "Manual Settings" in the "Set Up Mail Client" option in cPanel and in the automatic configuration scripts. I'll update this thread with more information on this case as it becomes available. In the meantime, you can manually update the email client to use "domain.com" to ensure the correct certificate is utilized.

    Thank you.
     
  6. AusDataHost2

    AusDataHost2 Registered

    Joined:
    Jun 21, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Iv just had this issue and the problem is the lack of mail. subdomain setup in apache.

    If found if i remove the DNS entry for mail.<domain>, add the mail.<domain> sub domain via cpanel (and also install a lets encrypt cert for mail.<domain>) it works perfectly.

    Changing the incoming server would be easier but with existing setups its not always easy e.g. Apple Mail does not allow it to be changed once an account is setup.

    Bit manual but works for me for now.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    649
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page