The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail-SPF-v2.005 trying to install every night in upcp

Discussion in 'E-mail Discussions' started by verdon, Jul 9, 2007.

  1. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Hi,

    For the last 5 or 6 days, I've been getting the same thing in my nightly upcp. It looks as if Mail-SPF-v2.005 is trying to install every night. I can't see any error and I don't recall seeing this before. I wonder if anyone can shed some light...

    Code:
    Running make for J/JM/JMEHNLE/mail-spf/Mail-SPF-v2.005.tar.gz
    Checksum for /home/.cpan/sources/authors/id/J/JM/JMEHNLE/mail-spf/Mail-SPF-v2.005.tar.gz ok
    Mail-SPF-v2.005/
    Mail-SPF-v2.005/INSTALL
    Mail-SPF-v2.005/CHANGES
    Mail-SPF-v2.005/SIGNATURE
    Mail-SPF-v2.005/lib/
    Mail-SPF-v2.005/lib/Mail/
    Mail-SPF-v2.005/lib/Mail/SPF/
    
    ... 
    a bunch more like that, then 
    ...
    
    CPAN: Module::Build loaded ok (v0.2808)
    
      CPAN.pm: Going to build J/JM/JMEHNLE/mail-spf/Mail-SPF-v2.005.tar.gz
    
    # running Build.PL 
    /usr/bin/perl Build.PL
    Creating custom builder _build/lib/MyModuleBuilder.pm in _build/lib
    Checking whether your kit is complete...
    Looks good
    
    Checking prerequisites...
    Looks good
    
    Creating new 'Build' script for 'Mail-SPF' version 'v2.005'
    /usr/bin/perl Build --makefile_env_macros 1
    Copying lib/Mail/SPF/v1/Record.pm -> blib/lib/Mail/SPF/v1/Record.pm
    Copying lib/Mail/SPF/Mech/All.pm -> blib/lib/Mail/SPF/Mech/All.pm
    Copying lib/Mail/SPF/Mech/A.pm -> blib/lib/Mail/SPF/Mech/A.pm
    
    ... 
    a bunch more like that, then 
    ...
    
    Copying bin/spfquery -> blib/script/spfquery
    Deleting blib/script/spfquery.bak
    Copying sbin/spfd -> blib/sbin/spfd
    Manifying blib/script/spfquery -> blib/bindoc/spfquery.1
    Manifying blib/lib/Mail/SPF/Mech/PTR.pm -> blib/libdoc/Mail::SPF::Mech::PTR.3
    Manifying blib/lib/Mail/SPF/Mech.pm -> blib/libdoc/Mail::SPF::Mech.3
    ... 
    a bunch more like that, then 
    ...
    
      JMEHNLE/mail-spf/Mail-SPF-v2.005.tar.gz
      /usr/bin/make -- OK
    Running make install
    /usr/bin/perl Build --makefile_env_macros 1 install
    Installing /usr/share/man/man1/spfquery.1
    Skipping /usr/lib/perl5/site_perl/5.8.8/Mail/SPF.pm (unchanged)
    Skipping /usr/lib/perl5/site_perl/5.8.8/Mail/SPF/MacroString.pm (unchanged)
    Skipping /usr/lib/perl5/site_perl/5.8.8/Mail/SPF/SenderIPAddrMech.pm (unchanged)
    ... 
    a bunch more like that, then 
    ...
    
    Installing /usr/share/man/man3/Mail::SPF::Mech::PTR.3
    Installing /usr/share/man/man3/Mail::SPF::Mech.3
    Installing /usr/share/man/man3/Mail::SPF::SenderIPAddrMech.3
    ... 
    a bunch more like that, then 
    ...
    
    Skipping /usr/sbin/spfd (unchanged)
    Skipping /usr/bin/spfquery (unchanged)
    Writing /usr/lib/perl5/site_perl/5.8.8/i686-linux/auto/Mail/SPF/.packlist
      JMEHNLE/mail-spf/Mail-SPF-v2.005.tar.gz
      /usr/bin/make install UNINST=1 -- OK
    Mail::SPF::Query is up to date (1.999.1).
    
    The same thing happens if I run checkperlmodules Of interest is that after I run checkperlmodules it will tell me that it Tested 96, 96 ok, 0 failed but it will continue to try installing Mail-SPF with subsequent runs.

    Any suggestions?
     
  2. pross

    pross Well-Known Member

    Joined:
    Mar 14, 2005
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Code:
    Skipping /usr/sbin/spfd (unchanged)
    Skipping /usr/bin/spfquery (unchanged)
    Writing /usr/lib/perl5/site_perl/5.8.8/i686-linux/auto/Mail/SPF/.packlist
      JMEHNLE/mail-spf/Mail-SPF-v2.005.tar.gz
      /usr/bin/make install UNINST=1 -- OK
    Mail::SPF::Query is up to date (1.999.1).
    Mail::DKIM is up to date (0.26).
    IP::Country is up to date (2.23).
    Graph::Easy is up to date (0.55).
    Graph::Flowchart is up to date (0.10).
    cPCPAN: Module (Mail::SpamAssassin) holdback (3.002001 held back to 3.2.1)
    
    exactly the same...every night!
    WHM 11.2.0 cPanel 11.6.0-R15032
     
  3. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
  4. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Thank you for the info
     
  5. Bailey

    Bailey Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    120
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Wisconsin
    Thank you, I had been wondering as well. :)

    :D Bailey
     
  6. a66fm

    a66fm Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Greece
  7. krisdv

    krisdv Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Belgium
  8. a66fm

    a66fm Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Greece
    still there

    yes it's still there!!!:confused:
     
  9. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
  10. Fernis

    Fernis Well-Known Member

    Joined:
    Oct 28, 2006
    Messages:
    192
    Likes Received:
    1
    Trophy Points:
    18
    I have this same issue.
     
  11. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    I think we all do. It's not a cpanel/whm issue. AFAIK, it's a bug with cpan (Comprehensive Perl Archive Network) and will be resolved when they have made a new release.
     
  12. krisdv

    krisdv Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Belgium
    Problem solved after yesterdays upcp run.
     
Loading...

Share This Page