Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

mail to postermaster account after exim upgrade - problem?

Discussion in 'E-mail Discussion' started by Jeff-C, May 13, 2004.

  1. Jeff-C

    Jeff-C Well-Known Member

    Joined:
    Mar 16, 2004
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    166
    After the exim upgrade, I see that dnsreport.com reports:
    Is this a problem that should be corrected, or intentional by design in the new exim RPMs?
     
  2. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,504
    Likes Received:
    1
    Trophy Points:
    318
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Normally, that error refers to Domain literals -- or using an IP address -- for postmaster. If it is not working for the Domain name then most likely the 'catch-all' is not being used and no address/forwarder was setup for postmaster.

    So, set one up and the problem will go away. Dont' worry about the error msg. for an IP address as most people don't accept any eMail sent to an IP address anyway.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Jeff-C

    Jeff-C Well-Known Member

    Joined:
    Mar 16, 2004
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    166
    Thanks very much Rob,

    So I need to setup a postmaster@ email alias/forwarder under each individual account? Is there a way to do it more easily (server-wide all at once) to comply with the standard instead of for each individual account?
     
  4. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,504
    Likes Received:
    1
    Trophy Points:
    318
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    It only needs to be done for accounts that are not using the 'catch-all' eMail which is default setup. If it is turned off or not used and a worry, then an address or forwarder needs to manually be setup for each account.

    It could be done using a custom made script if you want to go that route, but the manual method, although slower, is probably quicker & easier.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    316
    I dont think that is the answer. My guess is the problem involves a "hyphen" in the actual domain name. Is that correct Jeff C?
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice