Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

mail troubleshooting

Discussion in 'E-mail Discussion' started by Winstonnnn, Sep 14, 2005.

  1. Winstonnnn

    Winstonnnn Member

    Joined:
    Aug 30, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    Hi,

    I have been receiving a lot of mail problems lately, and wondered if any of you here could help me develope a set criteria to checking if al ok on the server.

    First I check in /etc/localdomains and /etc/valiases
    The I have a look in /etc/userdomains to make sure they are mapped correclty.

    Please can someone give me some more commands and guide to sorting out a mail problem

    Ie if exim -bt reports delivery is ok and I've checked the above, what else do I need to check.

    How to check quotas in shell in human readable format.

    An easy and quick way in shell to determine if a domain or email account is over quota.

    Any more commands or suggestions you may will be much appreciated.

    Basically I'm looking for a step by step guide with commands that will solve all my mail issues, so I can confidently tell the client, there is nothing wrong on the server, and your mail is being delivered etc.

    Thank you in advance. Winston.
     
  2. jacks

    jacks Active Member

    Joined:
    Nov 15, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    156
    Don't we all need that step-by-step guide to make our life easier. well; There are many commands related to email troubleshooting, but you need to know the problem first to issue/use the right command.
     
  3. Winstonnnn

    Winstonnnn Member

    Joined:
    Aug 30, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    Yes, would love that :)

    I'm asking for advice as since updates of 3 weeks ago, mail is an ongoing issue.

    I would like to know how you or any other knowledgavle person begins fault find.

    If you could lay out some steps, and commands I would appreciate it greatly.

    Ie, where do you look first, and if thats ok, where to now.

    I normally start with exim -bt user@domain.com

    Then go to /etc/localdomains and then /etc/valiases and then /etc/vailiases/domain.com

    etc etc.

    Please help as I need to resolv things quicker.
     
  4. jacks

    jacks Active Member

    Joined:
    Nov 15, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    156
    sorry, pal. i am not a sys admin and i think you need professional help.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    The first place to start is always /var/log/exim_mainlog (on Linux systems) and to identify and locate the errors pertaining to the problem you are investigating. Investigation follows from there. Helpful scripts to run as a matter of course:

    /scripts/updateuserdomains
    /scripts/mailperm


    And always check that the DNS servers in /etc/resolv.conf are actually resolving properly.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Winstonnnn

    Winstonnnn Member

    Joined:
    Aug 30, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    Hi Chirpy,

    I think I need more help.

    I have run those scripts and they have not helped.

    I updated Cpanel still on 10.2 stable

    I have eximup --force

    Checking everything in localdomains and valiases etc all correct.

    Checked resolv.conf - all is sane also.

    exim_mainlog reports a boxtrapper error for most non-functioning addies.

    error is either local delivery failed
    --or
    2005-09-15 13:32:30 1EFrya-0003r1-Fq ** user@domain.com R=boxtraper_autowhitelist T=boxtrapper_autowhitelist: Child process of boxtrapper_autowhitelist transport returned 255 (could mean shell command ended by signal 127 (Unknown signal 127)) from command: /usr/local/cpanel/bin/boxtrapper


    2005-09-15 13:32:30 1EFrya-0003r1-Fq <user@domain.com>: boxtrapper_autowhitelist transport output: Time::HiRes object version 1.65 does not match $Time::HiRes::XS_VERSION 1.73.


    Does n e one have n e suggestions...I'm at a loss
     
  7. Winstonnnn

    Winstonnnn Member

    Joined:
    Aug 30, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    anyone..........??????
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    The boxtrapper errors have been discussed at some length on the forums. Try a search for Time::HiRes
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice