The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail Wont Work Help!!

Discussion in 'E-mail Discussions' started by Getox, Dec 11, 2004.

  1. Getox

    Getox BANNED

    Joined:
    Feb 4, 2004
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    0
    its been like this for like this for like over 6 hours
    and i need it fixed ASAP!
    the server wont take in any mail
    my data centre has had a level 3 tech try to fix it and NOTHING!

    they said the mailscanner is stable
    they have restarted it multiple times and still nothing!

    i need help real bad!
     
    #1 Getox, Dec 11, 2004
    Last edited: Dec 11, 2004
  2. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    what does /var/log/exim_mainlog say ?
     
  3. Getox

    Getox BANNED

    Joined:
    Feb 4, 2004
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    0
    id post what it has here but i dunno if its save or not

    so ill just paste little bits of it

    SIGHUP received: re-exec daemon
    -q1h, listening for SMTP on port 25 (IPv4)
    {email} routing defer (-51): retry time not reached
    -q1h, not listening for SMTP
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You've most likely had exim upgraded and the new split spool setup in the configuration file. If you installed using my script or layer1 MailScanner, then if you upgrade using my package it will fix it:
    http://www.webumake.com/free/mailscanner.htm

    Alternatively, set the following in the first textbox of the WHM > Exim Configuration Editor:

    split_spool_directory = no
     
    EdRooney likes this.
  5. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    What about the messages?

    Hi Chirpi,

    We found we had the same problem with our boxes.
    What about the messages sent during the config problem, are they losted for ever?
    Is there any way to recover/send those messages?
    We receved fine, but no mail was sent.

    Thanks
    Gustavo


    BTW: Is cPanel trying to boicot the use of mailscanner? I don't beleived they didn't anounced this problem. The had mailscanner in their layer1 not much long ago ....
    What's the "offcial alternative" to mailscanner? Do you have any news regarding a virus scanning? otherwise they are promoting the spread of viruses, they don't have a solution and break the actual ones???, I don't get it ...
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Hi, it depends on how you fixed the problem. If you corrected MailScanner then they should still have been help in the /var/spool/exim_incoming/input/* directories and would have been picked up once MailScanner started working. If you switched off the split spools, then the emails will still be in the subdirectories and can be copied up to the parent directory for processing. If you uninstalled MailScanner, then they're gone.
     
  7. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Thank you very much!

    We moved all messages to the queue!

    Thank you again
     
  8. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    /usr/cpanel/"mailman" = chirpy ;)
     
  9. parser

    parser Member

    Joined:
    Aug 22, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Israel
    Queu

    How to move all emails to Queue?
    And what dirictory name of Queue? -> /var/spool/exim_incoming/input

    I have many directorys (0,1,2,...,a,b,...z) from them i need to copy?


    Thanks
    David
     
  10. equens

    equens Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    270
    Likes Received:
    0
    Trophy Points:
    16
    Email problems since last update!

    I have updated cpanel to WHM 9.9.9 cPanel 9.9.9-S15 and Mail Wont Work!!
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you want anyone to help, you're going to have to give more information than that! IF you're running MailScanner, do a search for "mailscanner split spool" on the forums for a variety of way to fix it. If you're not, you going to have to post details and errors from your mail logs.
     
Loading...

Share This Page