The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mailbox full error message

Discussion in 'E-mail Discussions' started by Eli_ch, Oct 14, 2003.

  1. Eli_ch

    Eli_ch Member

    Joined:
    Aug 18, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Switzerland
    if i try to send an email to a mailbox, who is full, i should normally get answer from exim like this:

    "This message was created automatically by mail delivery software (Exim).

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    test@eli.ch
    Disk quota exceeded:
    mailbox is full: retry timeout exceeded"

    but i didn't receive this message on every server from us.
    where can i config that??

    in mail queue of the whm i saw the right error message, but it isn't sent to me...

    "LOG: MAIN
    == test@eli.ch R=virtual_user T=virtual_userdelivery defer (-22): mailbox is full (MTA-imposed quota exceeded while writing to /home/elias/mail/eli.ch/test/inbox)"

    anyone knows something about that?
    thanks a lot for your help!

    cPanel.net Support Ticket Number:
     
  2. mickeymouse

    mickeymouse Well-Known Member

    Joined:
    Sep 16, 2003
    Messages:
    389
    Likes Received:
    0
    Trophy Points:
    16
    Dear Eli_ch,

    Edit the configure file. Add the following entries,
    To warn at a certain percentage and the message that will be sent to the owner of the mailbox:
    quota_warn_threshold = 75%
    quota_warn_message =\"\\
    To: $local_part@$domain\\n\\
    Subject: Warning - Almost out of email space\\n\\
    This is an automated email.\\n\\
    \\n\\
    The storage space used by your email has \\
    almost exceeded the allowed limit.\\n\\
    Please delete some emails, especially those \\
    with attachments, to free up space.\\n\\
    Otherwise email will stop being delivered \\
    until you do so.\\n\"

    For more information regarding this,refer the URL:

    http://www.flatmtn.com/computer/Linux-Exim4.html

    Regards,
     
  3. bradandersen

    bradandersen Active Member

    Joined:
    Oct 6, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Where do I modify the exim.conf file?

    I've made mods in:

    /etc/exim.conf
    /etc/exim.conf.dist
    /etc/exim.conf.localopts

    and they all get overwritten with some magical exim.conf file that is hidden somewhere.

    Thanks,
    Brad
     
  4. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    Any changes you want to be permanent should be made through the exim advanced configuration script in WHM. This will stop upcp from over writting your custom directives.
     
  5. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    Thanks, this is just what I'm looking for (in fact it's kind of shocking that quota_warn emails aren't generated by default - I can't believe I have to tweak settings to enable this -- having customer emails suspended without warning is unacceptable, or so say my customers, and I have to say I agree).

    Anyway, i added the quota_warn lines shown above, but got an "Invalid configuration syntax" error on exim restart. Wasn't quite sure which section of the exim config I should add it to.

    Suggestions? Thanks.
     
    #5 shacker23, Sep 2, 2005
    Last edited: Sep 2, 2005
Loading...

Share This Page