The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mailbox Overquota???

Discussion in 'E-mail Discussions' started by Francisco, Aug 19, 2005.

  1. Francisco

    Francisco Well-Known Member

    Joined:
    Jun 3, 2003
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    I am wondering, have this problem, a customer told me now (10PM) that she wasn't able to receive e-mail all morning (got notthing from the server on POP or Squirelmail), when I check her account, I noticed her quota was 10Mb Set on her account, but show disk usage said 27MB !! :eek:

    Now, I cleared her trash bin in Squirelmail and Neomail trash, and now that is gone. Now is back to 0.

    Before I noticed the Over Quota e-mail, I sent several tests to her account, and got no errors from my ISP to server (no rejected mail or anything), were the e-mails lost??

    Now, after clearing the crap folders and changing quota from 10MB to 500MB all seemed to work, sent e-mail and everything. Working as it should.

    Now, will the other e-mails be received at a later time?? (I am guessing Exim gave Mailbox un-available error so it is pending queue on other isps)

    Thanks
     
  2. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
    It depends on your Exim configuration. In the Exim Configuration Editor, there is an option "Discard emails for users who have exceeded their quota instead of keeping them in the queue." With that enabled, email would have bounced back to the senders. With it disabled, the email will possibly still be in your mail queue.
     
  3. Francisco

    Francisco Well-Known Member

    Joined:
    Jun 3, 2003
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6

    Crap, it's not selected... What can I do? :(
     
  4. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    select it?
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If the email is not in your email queue, it will be lost. You can try forcing an email queue run in WHM > Mail Queue Manager
     
  6. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    I *don't* have that box checked, which means that over-quota email *should* be in the queue. But after fixing a user's over-quota mailbox, he seems to have lost two days worth of email.

    A) If a search for his email address in the queue window doesn't turn anything up, then his mail is gone for good, right? Or is there any hope of retrieving it?

    B) What could be going wrong here? Why would his mail not be stored in the queue?

    Thanks,
    Scot
     
  7. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    What are the Retry Options at the bottom of exim.conf set for? You tell exim how long to hold the mail for there. That could explain why the mail is gone -held in quque too long.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If it's not there it is gone for good.
    As lloyd_tennison it does depend on the queue settings, but aftera few days it will drop off the queue anyway and be lost.
     
  9. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    Thanks both. Turns out that the user lost mail for four days, rather than two, and that the queue retention value was set to 4 days. So things were working properly as far as that was concerned. Much more troubling is that the user received zero warning that his account was approaching quota, which would have easily prevented all of this. Looking into that now...
     
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I've checked the exim reference manual and you can add the %age warning message, but not through the exim configuration editor.

    You will need to edit /etc/exim.conf and search for the two lines that start:

    quota =

    After each of those lines add the line:

    quota_warn_threshold = 75%

    Then restart exim. That ought to work (not tested). Unfortunately, when the next exim upgrade happens those changes will be overwritten. If you find that it does indeed work, then I would suggest logging a bugzilla enhancement request and posting the link back here for others to vote on asking cPanel to implement what I've described above.
     
  11. Bruce

    Bruce Well-Known Member

    Joined:
    Oct 4, 2001
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Your not the only one with an e-mail quota problem.
    Ever since we did the maildir change over, clients e-mail usage is not showing the correct numbers in cpanel.
    An account can have 17MB but the usage shows .06MB in cpanel and there is so much junk to clean up in the clients Mail directory folders. Really not sure what can be manually deleted anymore.
    Hundreds of customers on multiple servers.
    I cant be the only one with this problem ?
     
    #11 Bruce, Sep 3, 2005
    Last edited: Sep 3, 2005
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Since maildir isn't for production use yet it is likely to be buggy. I'd suggest logging a bugzilla entry if you have maildir problems so that they can investigate your server config and sort out any bugs.
     
  13. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    Thanks Chirpy. Did that and ran a test account over quota. Senders to the account get a "message delayed" response, but the account owner does not get a warning. I'll search the bug database and file a new one if necessary.

    I assume that exim would be smart enough to still deliver warning messages rather than hold them in the queue if the account is over quota. Hmm... Maybe I'd better take the test account just under its quota to test for this possibility.
     
  14. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I very much doubt that it will deliver a threshold warning if you are actually over it.
     
  15. Bruce

    Bruce Well-Known Member

    Joined:
    Oct 4, 2001
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    We always got warnings about email over quota. One sent to e-mail account and one sent to contact info on user account. Now no warnings since the maildir changeover.
    The right numbers do not show up in Cpanel / Manage and Add e-mail account /disk usage
    This maybe were the e-mail quotas are checked ?
    Bug added about maildir http://bugzilla.cpanel.net/show_bug.cgi?id=3172
     
Loading...

Share This Page