The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mailbox Question

Discussion in 'E-mail Discussions' started by evisions, Apr 13, 2004.

  1. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    I'm having a strange occurance that is impacting a couple of my accounts at least. [perhaps all of them]

    Email accounts seem to have a doubling of their inbox. Here is an example:

    in mail there are the following files/directories:
    user1/
    user2/
    inbox
    domain.com/
    spam

    under user1 and user2 there is just an inbox file which make sense. However in domain.com/ all the accounts are repeated:
    user1/
    user2/

    inside those directories there is:
    inbox
    inbox.pop
    spam

    or

    inbox
    INBOX.Drafts
    INBOX.Sent
    INBOX.Trash
    spam

    or in one case
    inbox
    domain
    spam

    Ok, so here is the issue. It seems that when the users are checking their email they are only getting email from one of the inboxes. When cpanel shows how much disk space the mail accounts are using it is also only showing the disk space for one of the boxes. However, when the quota is calculated it uses both..... So, these accounts are running out of disk space and the users can't clear it up (or even easily see it).

    The inbox information is not the same for mail/user1/inbox and mail/domain.com/user1/inbox - its different.

    Why is this happening? Is it something to do with webmail vs. pop or imap vs. pop?

    How do I correct this and prevent it from happening in the future?

    Thanks,
    Chad
     
  2. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
  3. Big Gorilla

    Big Gorilla Active Member

    Joined:
    Jan 30, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    mail/user1/inbox and mail/domain.com/user1/inbox should be exactly the same.... they are the same file (share an inode... they are hardlinked... at least they are supposed to be).
     
  4. synax

    synax Member

    Joined:
    Jun 24, 2002
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    I am noticing the same problem, did you ever find a fix for this?
     
  5. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    No, I never found a fix, and the inboxes are not the same for users I'm having issues with.
     
  6. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    I'm wondering if anyone else has any insight into this issue. I have a user currently that is complaining that he can't receive mail. So, I looked at his account and of the two inboxes one has mail, the other doesn't:

    mail/domain.com/user/inbox has mail
    mail/user/inbox has none

    When I send email to this user it goes into the mail/domain.com/user/inbox and not the other box.

    Looking at my own mailbox on the same server (which is working fine) I see the two inboxes are identical.

    How do I correct this issue?
     
  7. nabeelj

    nabeelj Registered

    Joined:
    Jun 18, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hamilton, Ontario, Canada
    I had a similar problem once. Fixed it by simply deleting the email account, manually deleting /mail/domain.com/user/*, then recreating the email account. I couldn't figure out a cleaner way of doing it.
     
Loading...

Share This Page