The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mailconfigupdate + RBL ACL + ClamAV

Discussion in 'E-mail Discussions' started by Bdzzld, Aug 31, 2007.

  1. Bdzzld

    Bdzzld Well-Known Member

    Apr 3, 2004
    Likes Received:
    Trophy Points:

    Recently our servers were upgraded to the latest stable version of cPanel and we received the following message, which is probably known to a lot of us and has been discussed earlier :

    cPanel was unable to automatically merge your Exim configuration with the new settings that shipped 
    with the build you have installed (11.10.0-STABLE_16448) because you have a custom ACL configuration 
    which cannot be automatically configured.  To avoid any mail downtime, we thought it was best to leave 
    your previous configuration intact until the new configuration can be properly installed.  In order to 
    complete this configuration update, you will need to manually merge your configuration with the new 
    configuration settings.  Please follow the steps below to complete this update:
            1. Enter WHM at https://SERVER:2087/
            2. Enter the Exim Configuration Editor:
                            (Service Configuration >> Exim Configuration Editor >> Advanced Configuration Editor)
            3. Notate any custom changes you have made in the ACL section.
                            You may also which to make a copy of /etc/exim.conf.local
                            and /etc/exim.conf.localopts as it they your custom settings.
            4. Click the 'Reset ACL Config to Defaults' button.
            5. Reinstall your advanced custom settings.
    Note: Until you manually complete this update, automatic spam filtering has been rendered inoperable to
    prevent any mail loss. 
    Our servers all have custom ACLs as described here and also run cPanel's ClamAV Scanner.
    What's the best way to deal with this ?

  2. nabuhonodozor

    nabuhonodozor Member

    Jun 22, 2007
    Likes Received:
    Trophy Points:
    Ive just encounter similar thing.
    Earlier I had clamav and some "HELLO" rules set up in my exim.conf file.
    What I had to do was to manually backup Your exim config files, then follow instructions in cPanel message and than edit config files again.
    I also spoted that I dont have to manually config clamav because now its somehow configured by cPanel.
    best regards,
    Piotr E

Share This Page