The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mailman 2.1.11.cp2 core dump

Discussion in 'E-mail Discussions' started by vlsoft, Sep 30, 2008.

  1. vlsoft

    vlsoft Registered

    Joined:
    Jan 11, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi!

    I have noticed that after our server's mailman update (which occured on 09/25/2008), the OutgoingRunner terminates with signal 11.

    I found lines like these in logs/qrunner (only pasted the last few, they're all similar):
    Sep 30 14:19:48 2008 (20366) Master qrunner detected subprocess exit
    (pid: 20374, sig: 11, sts: None, class: OutgoingRunner, slice: 1/1) [restarting]
    Sep 30 14:19:48 2008 (20381) OutgoingRunner qrunner started.

    There are core.QWXYZ files in /usr/local/cpanel/3rdparty/mailman .

    What should I do? I have already tried running /scripts/fixmailman, cleaning the subdirs under qfiles and restarting mailman; but all messages go from qfiles/out to qfiles/bad, and on each message an OutgoingRunner terminates abnormally (even on mailman's own messages, the list-join/leave replies)!

    I've even tried a lame attempt to downgrade mailman using /usr/local/cpanel/src/3rdparty/gpl/mailman-2.1.9, doing a "make install", but that's impossible as it writes out on one of the Compiling lines, that
    Downgrade detected, from version 0x2010bf0 to version 0x20109f0
    so this fails also. Of course I have backed up all mailman stuff, so after the failed attempt I have restored the 2.1.11.cp2 version (which is just as bad as before :\ ).

    By the way, the system is an old Trustix Secure Linux box, mailman 2.1.11 is configured like this by cPanel:
    configured by ./configure, generated by GNU Autoconf 2.59,
    with options \"'--with-cgi-gid=99' '--with-mail-gid=12' '--with-python=/usr/local/bin/python2.4' '--prefix=/usr/local/cpanel/3rdparty/mailman'\"

    The 2.0.9 was using python 2.2 (which is still present on the system), it was configured like this:
    ./configure --with-cgi-gid=99 --with-mail-gid=12 --with-python=/usr/bin/python2.2 --prefix=/usr/local/cpanel/3rdparty/mailman --no-create --no-recursion

    Any ideas? Should I post a support ticket?
     
  2. vlsoft

    vlsoft Registered

    Joined:
    Jan 11, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Okay, replying to my own thread, nice...

    So one of our clients _really_ wanted to send mail through mailman, and I have done something I usually don't:

    # wget 'http://httpupdate.cpanel.net/cpanelsync/STABLE/bin/mailman-install.bz2'
    # bzip2 -d mailman-install.bz2

    Now I have edited mailman-install, there was a line at the first few lines with "my $python", modified to look like this:
    my $python = '/usr/bin/python2.2';

    Now the script won't install this because this is the current version, so hack away in /usr/local/cpanel/3rdparty/mailman/Mailman/Version.py and replace the 11 with 10 or something (in the VERSION variable and in MICRO_REV).

    # chmod 755 mailman-install
    # ./mailman-install

    This installed a hacked mailman version, and it seems this works. Of course the next cPanel update will screw up mailman (again), but what not, I'll do this again...

    The "seems this works" wasn't checked thoroughly, I sent a mail to the list-leave address, and the confirmation mail is here in my inbox, so I just assumed that other letters will be able to go through too.
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The most effective method of receiving a response from our technical analysts is to submit a support ticket. As this forum is not an official means of support, technical analysts rarely post to these forums.
     
Loading...

Share This Page