The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mailman cannot send through exim - localhost rejected

Discussion in 'E-mail Discussions' started by dxm, Nov 27, 2013.

  1. dxm

    dxm Active Member

    Joined:
    Aug 1, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    Today our mailman server cannot send out emails anymore.
    The error we are getting is:

    2013-11-27 13:01:56 H=localhost (host.server.com) [::1]:49906 F=<list-address-bounces@MYSITE.com> rejected RCPT <user@domain.com>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message. localhost (host.server.com) [::1]:49906 is not permitted to relay through this server without authentication.

    We haven't changed anything so perhaps an update has caused this?
    It appears that the mailmain software is trying to connect to exim and it is being rejected (for each recipient).

    Any ideas?
     
  2. dxm

    dxm Active Member

    Joined:
    Aug 1, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Actually I think this has been broken for longer.
    A lot of files were updated on the 8th of November.
    We have a web form that uses php to send an email to the list address, on the same server.
    The email from the form is delivered to mailman ok it seems, and then when mailman tries to send the emails to the recipients exim rejects each message with the error in my previous post.

    So it looks like there is a problem with how mailman injects the emails into exim or how exim 'precieves' them.

    Any help greatly appreciated!
     
  3. LoopZilla

    LoopZilla Registered

    Joined:
    May 25, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London
    Yes, I put in a ticket about this. I thought is happened on November 7th (2013).

    I have no solution, and neither did cPanel. I closed the ticket.

    LZ

    - - - Updated - - -

    cd /usr/local/cpanel/3rdparty/mailman/logs

    tail smtp-failure

    Nov 24 19:38:16 2013 (10680) All recipients refused: {'user@domain.com': (550, 'Please turn on SMTP Authentication in your
    mail client, or login to the\nIMAP/POP3 server before sending your message. localhost\n(recuraa5.servrdomain.com) [::1]:
    37997 is not permitted to relay through\nthis server without authentication.')}, msgid: <mailman.0.1385321895.10913.test_
    domain.com@domain.com>
    Nov 24 19:38:16 2013 (10680) delivery to user@domain.com failed with code 550: Please turn on SMTP Authentication in your
    mail client, or login to the
    IMAP/POP3 server before sending your message. localhost
    (recuraa5.servrdomain.com) [::1]:37997 is not permitted to relay through
    this server without authentication.
     
    #3 LoopZilla, Nov 29, 2013
    Last edited by a moderator: Nov 29, 2013
  4. dxm

    dxm Active Member

    Joined:
    Aug 1, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Could someone from cPanel comment on this? i.e. should I submit a ticket to cPanel or is there no known cause or solution to this problem?
     
  5. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Do you mind sharing the ticket number, so that we can follow up on it?
     
  6. dxm

    dxm Active Member

    Joined:
    Aug 1, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Jared, have you followed up on this other ticket?
     
  7. LoopZilla

    LoopZilla Registered

    Joined:
    May 25, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London
    The ticket was ID# 4398337

    The current position is that my ISP supplies cPanel/WHM with an "unsupported kernel", so I have asked my ISP for comment.

    I have reopened the ticket.

    LZ
     
Loading...

Share This Page