Mailman does not send mail to the list

tarmo

Member
Feb 1, 2005
17
0
151
Hello,

it started 2 days ago.
mailman will accept the mails but do not forward them to list member (no errors on exim logs). I tried everything. Mailman reinstall, restarted all services but nothing.

Exim 4.52 / WHM 10.8.0 cPanel 10.8.2-R115.

And there are core.* (numbers) in /usr/local/cpanel/3rdparty/mailman folder.

What else I can do?

EDIT:
Sorry.
OS is Trustix, I downloaded the lates python 2.4.3. Installed, but python -V shows the old python Python 2.2.3!

Core include something like this:
"ii{ż˙æi686/usr/local/bin/python2.4/usr/local/cpanel/3rdparty/mailman/bin/qrunner--runner=OutgoingRunner:0:1-sPASS=CPANEL=activeSSL_PROTOCOL_VERSION=3
HOST=www.econet.ee:2087LC_ALL=CNEWWHMUPDATE=1USER=rootHTTPS=onSUBID=PATH=/sbin:/bin:/usr/bin:/usr/sbin:/sbin:/usr/sbin:/usr/bin:/bin:/usr/local/bin:
/usr/local/bin:/sbin:/usr/sbin:/usr/bin:/bin:/usr/local/bin:/usr/local/binPWD=/WHM50=10.8.0LANG=CUPLINK=SHLVL=1HOME=/root
LD_ASSUME_KERNEL=2.4.1NOWHOSTMRRES=NONOBADQUERY_STRING=CPRSYNCSERVER=layer2.cpanel.netCPBUILD=CURRENTREQUEST_METHOD=
GET_=/usr/bin/perlSCPHTTPUPDATESERVER=httpupdate.cpanel.net/usr/local/bin/[email protected] [/usr/local/cpanel/3rdparty/mailman]#"

I will try upcp --force.
If I want to downgrade (right now I tried EDGE, before I always had CURRENT tree (and 2 day before I updates the cpanel)) is just choose Stable tree and update with --force?
 
Last edited:

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
Well, the core files are core dumps of the terminating processes - i.e. the application is crashing. You either need to find out how to read the core dumps (no mean feat) or try another approach:

1. You didn't mention your OS, but make sure it is up to date, especially python

2. Try a /scripts/upcp --force

If that doesn't help, you'll probably have to log a ticket with cPanel through your license provider to get help tracking down what's wrong.
 

tarmo

Member
Feb 1, 2005
17
0
151
I still have this problem. I have tried everything (I think). Upgraded to Edge version, New Pyhton install + patch, reinstalled mailman. But nothing. And I still see core.* files under mailman folder (they will come after i run /scripts/pyhtonup).

System default is 2.2 version, but I can see that 2.4 version of Python is also there and it is working.

Any ideas? Soon I must deliver those emails manually by foot :) if I cannot fix this.

Tarmo

Edit:

I also found this:
http://bugzilla.cpanel.net/show_bug.cgi?id=4166 someone has the same problem, but no answer yet :(
 
Last edited:

point

Member
Dec 1, 2003
7
0
151
I am having the same issue. OS is trustix as well, but I'm using STABLE

this message is repeated 10 times each time the qrunner service is restarted (/usr/local/cpanel/3rdparty/mailman/logs/qrunner):

May 30 11:33:13 2006 (19576) OutgoingRunner qrunner started.
May 30 11:33:14 2006 (19570) Master qrunner detected subprocess exit
(pid: 19576, sig: 11, sts: None, class: OutgoingRunner, slice: 1/1) [restarting]

removing all files in /usr/local/cpanel/3rdparty/mailman/qfiles/out and restarting the qrunner service allows it to start without crashing immediately however the next time it run's it crashes again.

I tried to add this information to the bug but it wouldn't let me update it
 
Last edited:

point

Member
Dec 1, 2003
7
0
151
found this from http://forums.cpanel.net/showthread.php?t=52822&page=2


wget http://layer1.cpanel.net/Python-2.4.3.tar.bz2

tar jxf Python-2.4.3.tar.bz2

cd Python-2.4.3

./configure --prefix=/usr/local --with-cxx=/usr/bin/c++

make

make install

make clean

wget -O /usr/local/cpanel/bin/mailman-install http://httpupdate.cpanel.net/cpanelsync/EDGE/bin/mailman-install

wget -O /usr/local/cpanel/src/3rdparty/gpl/patches/mailman-2.1.7.cpanel.patch http://httpupdate.cpanel.net/cpanelsync/EDGE/src/3rdparty/gpl/patches/mailman-2.1.7.cpanel.patch

/scripts/reinstallmailman

/usr/local/cpanel/bin/convertmailman2



It seems to be working for me...

[EDIT] Nope, still not working.

I've tried changing to CURRENT and doing upcp --force... and tried RELEASE and upcp --force... same results
 
Last edited:

Polidoor

Member
Jul 4, 2003
9
0
151
Have the same problems also Trustix OS , we tried everything found about Mailman on this board nothing works :(
 

tarmo

Member
Feb 1, 2005
17
0
151
point said:
I am having the same issue. OS is trustix as well, but I'm using STABLE

this message is repeated 10 times each time the qrunner service is restarted (/usr/local/cpanel/3rdparty/mailman/logs/qrunner):

May 30 11:33:13 2006 (19576) OutgoingRunner qrunner started.
May 30 11:33:14 2006 (19570) Master qrunner detected subprocess exit
(pid: 19576, sig: 11, sts: None, class: OutgoingRunner, slice: 1/1) [restarting]

removing all files in /usr/local/cpanel/3rdparty/mailman/qfiles/out and restarting the qrunner service allows it to start without crashing immediately however the next time it run's it crashes again.

I tried to add this information to the bug but it wouldn't let me update it
Very good at least I am not alone :) I have the same error. I have tried to update the python about 3 days, but still nothing. I try to add new case to bugzilla, maybe they can help us.

Edit:

I added the bugzilla:

http://bugzilla.cpanel.net/show_bug.cgi?id=4242
 
Last edited:

Polidoor

Member
Jul 4, 2003
9
0
151

point

Member
Dec 1, 2003
7
0
151
well I've had a ticket open for days now, still marked unassigned... does anyone even read them?

I've tried reinstalling mailman and python and verifying the binaries...

mailman is a collection of python scripts (it's like perl). the qrunner is executed from python. python is dumping core when the qrunner is run.

there are bugs in python which can cause it to crash.

What we have here is an incompatability between the version of python that the update pushed down to us, and the version of mailman the update pushed to us.

the mailman we have is patched to work with cpanel, so I wouldn't try changing versions of mailman.

we could try different versions of python tho.
 

tarmo

Member
Feb 1, 2005
17
0
151
To who we must call? If the lists doesn't work then no emails and no money.
Cpanel support where are you, we need your HELP.
 

point

Member
Dec 1, 2003
7
0
151
The best place to start is by opening a ticket thru your whm panel. It's found under Support -> Support Center -> Contact Cpanel

This may not be the correct way to open a ticket for everyone (depends on who provides your cpanel licensing?) but it worked for me (I pay for mine directly)

My ticket looks to be resolved. Tho I'm a little unsure of the method, the results seem to be satisfactory.

The cpanel rep changed mailman's qrunner to run from python2.2 (the rpm installed one) rather than 2.4 (the cpanel installed one) and the out queue is trying to catch up as I type this.

Good luck. I'll be keeping an eye on it for some time (and this thread)
 

pizzaman

Well-Known Member
PartnerNOC
Oct 1, 2003
70
0
156
Exact same problem. cPanel support helps fix it. Here's how.

Edit /var/cpanel/cpanel.config, changing the value of the python line to "/usr/bin/python2.2" (or whatever version of python is in /usr/bin on your server), and then run the following series of commands.

chattr +i /var/cpanel/cpanel.config
/scripts/reinstallmailman
chattr -i /var/cpanel/cpanel.config
I havn't tried if this will survive the next cPanel update.

Good luck.
 

tarmo

Member
Feb 1, 2005
17
0
151
Cpanel fixed my problem to.
"I've rebuilt mailman on your server against python 2.2."

And now my lists are working.
 

PDW

Well-Known Member
Dec 29, 2003
138
3
168
Just doing

/scripts/reinstallmailman

/usr/local/cpanel/bin/convertmailman2

This worked fine for me