Mailman is not distributing email from yahoo

nsjski

Member
Sep 8, 2013
5
0
1
cPanel Access Level
Website Owner
I set up a mailing list with mailman (2.1.15) in cpanel. I subscribed to it with 3 different email addresses - yahoo, hotmail and my work email. All 3 memberships have identical settings. For emails from the hotmail and work accounts, the mailing list works exactly as it should do. For the yahoo account, it returns a post acknowledgement to let me know that it received the email, it even files the email in the archive, but it does not send the email on to the other members. This is with identical emails from all 3 accounts.

I'm hoping that someone can explain this to me!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

Do you notice any differences with the Yahoo address in "/var/log/exim_mainlog"? You can search for each email address with a command such as:

Code:
exigrep [email protected] /var/log/exim_mainlog
Thank you.
 

nsjski

Member
Sep 8, 2013
5
0
1
cPanel Access Level
Website Owner
I took a look through the log files and found this in the section where it deals with an email from my yahoo account

2013-09-19 11:01:41 1VMfjh-0001Pu-9R DKIM: d=yahoo.com s=s1024 c=relaxed/relaxed a=rsa-sha256 t=1379602888 [verification failed - signature did not verify (headers probably modified in transit)]
2013-09-19 11:01:41 1VMfjh-0001Pu-9R H=localhost [127.0.0.1]:34283 rejected DKIM : DKIM: encountered the following problem validating yahoo.com: signature_incorrect

The next few entries are where the post acknowledgement is sent out to my yahoo email.

It looks like DKIM does not like Yahoo. Help!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
That indicates the message header was modified in transit which can prevent DKIM verification. You can turn off the following option under the "ACL Options" tab in "WHM Home » Service Configuration » Exim Configuration Manager":

"Reject DKIM failures"

This should allow the message to send out successfully.

Thank you.