Mailman lists not working after cpanel account copy/transfer to new server

ramonster

Member
Mar 4, 2007
8
0
151
Hi,

As topic says, I transferred my account (not using the "old" cpanel fallback method , it used the "reliable" new method apparently) and the 3 mailman lists are there, the users, settings etc are all under cpanel and mailman and I can see it looks fine.

The problem is, no email is actually flowing to or from any of the lists, its just not working at all with no indication in any logs/mail/exim etc return errors or such that theres a problem - theres no indication the email fails, no return to sender.

The new server is a fresh CentOS 5.4 with latest CURRENT build cpanel, previous server was same CentOS and cpanel.

Any ideas anyone? Much appreciated!
 

rishivispute

Member
May 23, 2010
11
0
51
pune
cPanel Access Level
Root Administrator
Twitter
Hi,

As topic says, I transferred my account (not using the "old" cpanel fallback method , it used the "reliable" new method apparently) and the 3 mailman lists are there, the users, settings etc are all under cpanel and mailman and I can see it looks fine.

The problem is, no email is actually flowing to or from any of the lists, its just not working at all with no indication in any logs/mail/exim etc return errors or such that theres a problem - theres no indication the email fails, no return to sender.

The new server is a fresh CentOS 5.4 with latest CURRENT build cpanel, previous server was same CentOS and cpanel.

Any ideas anyone? Much appreciated!
If you have migrated your account from one server to another server means HOSTNAME changed on new server and so you need to change the hostname in your mailman configuration.
 

ramonster

Member
Mar 4, 2007
8
0
151
Hi,

Yes hostname is a little different, but where abouts do I tweak mailmans hostname? The actual one in the general list options ("Host name this list prefers for email") is the short domain version and is fine, so not sure if theres a main mailman hostname somewhere else, can't see anything in /etc

Thanks for your input btw.
 

ramonster

Member
Mar 4, 2007
8
0
151
Solved!

Was due to recipient restrictions in Exim, and cpanel did not copy the mm_cfg.py VERP settings across causing a "too many recipients" reject, fixed by adding VERP options and restarting the mailmanctl.