The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MailMan Mailing List Problem

Discussion in 'E-mail Discussions' started by akaize, Jun 1, 2002.

  1. akaize

    akaize Member

    Joined:
    Jun 1, 2002
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Our host had Cpanel 4.7 and after upgrading to 4.8 all our Mailing lists are giving problem, non of the existing lists sends mails and when we try to create a new list getting the following error:

    Entry for aliases file:

    ## testmail_akaize.com mailing list
    ## created: 31-May-2002 akaize
    testmail_akaize.com: &|/usr/local/cpanel/3rdparty/mailman/mail/wrapper post testmail_akaize.com&
    testmail_akaize.com-admin: &|/usr/local/cpanel/3rdparty/mailman/mail/wrapper mailowner testmail_akaize.com&
    testmail_akaize.com-request: &|/usr/local/cpanel/3rdparty/mailman/mail/wrapper mailcmd testmail_akaize.com&
    testmail_akaize.com-owner: testmail_akaize.com-admin

    Hit enter to continue with testmail_akaize.com owner notification...
    Traceback (innermost last):
    File &/usr/local/cpanel/3rdparty/mailman/bin/newlist&, line 220, in ?
    main()
    File &/usr/local/cpanel/3rdparty/mailman/bin/newlist&, line 213, in main
    text)
    File &/usr/local/cpanel/3rdparty/mailman/Mailman/Message.py&, line 211, in __init__
    OutgoingMessage.__init__(self, text)
    File &/usr/local/cpanel/3rdparty/mailman/Mailman/Message.py&, line 205, in __init__
    self['Message-ID'] = Utils.make_msgid(idstring='Mailman')
    File &/usr/local/cpanel/3rdparty/mailman/Mailman/Utils.py&, line 764, in make_msgid
    idhost = socket.gethostbyaddr(socket.gethostname())[0]
    socket.error: host not found


    Need some support please?
     
  2. Reuben

    Reuben Active Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I just fixed this earlier today on one of my servers. You need to open up /etc/hosts and make sure there is an entry for your server as well as localhost.
     
  3. hostbet

    hostbet Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Can you post an example!
     
Loading...

Share This Page