Mailman needs to be fixed repeatedly

dory36

Well-Known Member
Aug 30, 2003
179
0
166
I have only one account using mailman on a particular server, and it periodically stops delivering mail, with no other symptoms (i.e., no bounces etc)

If I notice mail not going through, and run /scripts/fixmailman, then it starts back up and works ok for a while. But I have to notice it -- the messages sent in the meantime are just lost in the ether.

Any suggestions?

Thanks - Bill

PS: WHM 10.8.0 cPanel 10.9.0-R118
 

Tina

Well-Known Member
Jan 27, 2003
63
0
156
Me too

I have one client using mailman and he reports the exact problem. Any ideas or just reinstall?

Thanks, Tina
 

freedman

Well-Known Member
Feb 13, 2005
314
5
168
I have one client using mailman and he reports the exact problem. Any ideas or just reinstall?

Thanks, Tina
the fixmailman script removes pending outgoing messages in:
/usr/local/cpanel/3rdparty/mailman/qfiles/out

so, my guess is, something about the messages they're sending are getting mucked up by your mail server.

exim -bp
will list what's in your mail queue.. if mailman's messages aren't being accepted by your mail queue, then check your mail logs for why this would be.

if you aren't overly concerned about the outgoing mail queue, then just do this:
ln -s /scripts/fixmailman /etc/cron.daily

which will run the fixmailman script on a daily basis so you dont have to worry about it.. I'm guessing that some of their mailing list messages might get tossed out, but I dont know for sure.

good luck.
 

cretu

Well-Known Member
Jul 21, 2002
208
0
166
I am having the same problem.

No errors, bounced. I have rebuilt cPanel, Exim and only reinstalling Mailman seems to work. This is happening on very small volume server so I am seeking a solution.