Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Mailman - Not able to send outgoing mails

Discussion in 'E-mail Discussion' started by DeepXP, Apr 16, 2013.

  1. DeepXP

    DeepXP Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Internet
    cPanel Access Level:
    Root Administrator
    Mailman - Not able to send mails

    I have been trying to understand the reason why mailman cannot send the mail from our server.

    The smtp-failure log of mailman shows following output:

    Code:
    
    Apr 16 05:16:36 2013 (11703) Low level smtp error: (97, 'Address family not supported by protocol'), msgid: <mailman.2.1366101926.11701.test.list_example.com@example.com>
    
    Apr 16 05:16:36 2013 (11703) delivery to test.list-owner@example.com failed with code -1: (97, 'Address family not supported by protocol')
    I have replaced the actual domain with example.com

    I checked the port settings in firewall, 25, 26 are open (TCP In & Out). I even tried it after disabling the firewall but still same error.

    I have ASSP Deluxe installed but I believe, this has nothing to do with it as mailman directly connects to exim via port 125 (Yes, that's also open - TCP In)

    Any pointers?

    Thanks
    Deep
     
    #1 DeepXP, Apr 16, 2013
    Last edited: Apr 16, 2013
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    11
    Trophy Points:
    168
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Re: Mailman - Not able to send mails

    Only that is is a problem with IPv6.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DeepXP

    DeepXP Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Internet
    cPanel Access Level:
    Root Administrator
    Any ideas on the solutions? I could not fix it myself.
     
  4. simonas

    simonas Well-Known Member

    Joined:
    Apr 21, 2013
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lithuania
    cPanel Access Level:
    Root Administrator
    Go to advanced exim settings,

    Add custom value:

    disable_ipv6 true

    I always do that on new servers.
     
  5. DeepXP

    DeepXP Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Internet
    cPanel Access Level:
    Root Administrator
    I did that but still no help. Same error.
     
  6. DeepXP

    DeepXP Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Internet
    cPanel Access Level:
    Root Administrator
    I figured out the issue.

    I just commented the line

    SMTPPORT = 125

    located in /usr/local/cpanel/3rdparty/mailman/Mailman/pico mm_cfg.py

    and everything started working fine.

    I am not sure how that port specification ended up getting added though.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice