The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mailman not working in release 10.6

Discussion in 'E-mail Discussions' started by endelwar, Aug 20, 2005.

  1. endelwar

    endelwar Member

    Joined:
    May 2, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Earth
    cPanel Access Level:
    Root Administrator
    Just update to release 10.6-r16 and all my mailing list aren't working.
    in exim_maillog appear this:
    2005-08-20 20:23:20 1E6Y00-0001uU-69 ** aregar@aregar.it R=mailman_virtual_router T=mailman_virtual_transport: Child process of mailman_virtual_transport transport returned 127 (could mean unable to exec or command does not exist) from command: /usr/local/cpanel/3rdparty/mailman/mail/mailman

    the file doesn't exists in /usr/local/cpanel/3rdparty/mailman/mail:
    root@server1 [/usr/local/cpanel/3rdparty/mailman]# l mail
    total 12
    drwxrwsr-x 3 mailman mailman 4096 Aug 20 17:46 ./
    drwxrwsr-x 21 mailman mailman 4096 Aug 20 11:58 ../
    drwxrwsr-x 5 mailman mailman 4096 Aug 20 17:46 .mailman/
     
  2. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    WHM 10.6.0 cPanel 10.6.0-C15
    RedHat 7.3 i686 - WHM X v3.1.0

    Mailman is not working for me now either.
     
  3. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    OK, did some trooubleshooting.
    Old list is not working.
    Created a new list, and it works fine.
    Problem is we have several old lists...and I need them to work.
    Anyone else having mailman issues?
     
  4. endelwar

    endelwar Member

    Joined:
    May 2, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Earth
    cPanel Access Level:
    Root Administrator
    not in my case: created a test ml and exim_mainlog gives the same error (R=mailman_virtual_router T=mailman_virtual_transport: Child process of mailman_virtual_transport transport returned 127 (could mean unable to exec or command does not exist) from command: /usr/local/cpanel/3rdparty/mailman/mail/mailman)

    I think I need to reinstall mailman, but I need to not lose the old mailing lists
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Try running

    /usr/local/cpanel/3rdparty/mailman/mail/mailman

    directly to check for errors
     
  6. endelwar

    endelwar Member

    Joined:
    May 2, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Earth
    cPanel Access Level:
    Root Administrator
    as reported in my first post the directory /usr/local/cpanel/3rdparty/mailman/mail/ is empty

    root@server1 [/usr/local/cpanel/3rdparty]# /usr/local/cpanel/3rdparty/mailman/mail/mailman
    bash: /usr/local/cpanel/3rdparty/mailman/mail/mailman: No such file or directory
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    Please open a support ticket, your python version is probably too old.
     
  8. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Correct, we had to upgrade python to 2.4.1_3 last week as it failed and prevented python from restarting in tweak settings. This fixed it.
     
  9. endelwar

    endelwar Member

    Joined:
    May 2, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Earth
    cPanel Access Level:
    Root Administrator
    [fixed]

    root@server1 [~]# python -V
    Python 2.2.3

    as reported on mailman website "Mailman 2.1 requires Python 2.1 or newer, although Python 2.3 or newer is recommended." so 2.2.3 should suffice (http://www.gnu.org/software/mailman/mailman-install/node2.html).

    btw I've found the missing file in /usr/local/cpanel/src/3rdparty/gpl/mailman-2.1.6/src/ : after copying the file mailman in /usr/local/cpanel/3rdparty/mailman/mail/ the mailing lists restarted to work normally.
    The file was compiled correctly in the 10.2 -> 10.6 upgrade, but it wasn't copyed in the right position, I suppose.
     
  10. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Well, that doesn't explain why my old lists aren't working and the new ones do.
    Anyone else having this issue?
     
  11. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Please submit a support ticket.
     
  12. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    Which file you have copied so that I can try this too.I didn't understand that this error is for which file? I have Pyhton verison 2.2.3 but I am still geting error.

    I have also tried /scripts/fixmailman but still problem exists. I am on WHM 10.6.0 cPanel 10.8.0-S59 with RedHat 7.3 i686 .
     
    #12 DigitalSurgeon, Oct 11, 2005
    Last edited: Oct 11, 2005
Loading...

Share This Page