The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mailman Permission Errors

Discussion in 'E-mail Discussions' started by ladylinux, Apr 21, 2006.

  1. ladylinux

    ladylinux Member

    Jun 22, 2003
    Likes Received:
    Trophy Points:
    Baltimore, Maryland

    Reluctantly I updated to current from release primarily because I needed to get the Horde security update. Everything worked fine but mailman web interface gives off a error

    I go look at mailman error log .. Nothing .. I see this error in apache logs ..

    I look at permissions on /usr/local/cpanel/3rdparty/mailman/logs/error

    okw-rw-r-- 1 mailman mailman 0 Apr 21 22:22

    Whola maybe its because of permissions .. on a lark I say ok .. maybe I will chmod 666 that file .. Still get the error .. But now information is being written to this log file ... it seems that the config.pck file under lists/maillistname/ has a permission error .. I go ok .. I will bite .. lets chmod that lil guy to 664 from 660 ..

    Whola .. the lists start working ..

    So .. I say what is it that is wanting to access these files .. Hmmmm .. oh yah .. the web server user .. nobody .. sure enough .. chgrp nobody to all files with existing permissions and it works also.

    I am happy I got this to work .. But really am confused as to what the permissions should be ??? Anybody have a current release with working mailman and can shed any light ???


  2. lloyd_tennison

    lloyd_tennison Well-Known Member

    Mar 12, 2004
    Likes Received:
    Trophy Points:
    Try first running /check_perms and /check_db. That should fix the problems. But in answer to your question:

    drwxrwsr-x   4 mailman mailman     4096 Apr 13 13:17 ./
    drwxrwsr-x  24 mailman mailman     4096 Mar 15 14:04 ../
    -rw-r--r--   1 mailman mailman 31447462 Apr 25 00:36 bounce
    -rw-r--r--   1 mailman mailman  2713795 Apr 22 10:09 error
    -rw-r--r--   1 mailman mailman    32296 Apr 13 16:06 locks
    -rw-r--r--   1 mailman mailman   615158 Apr 24 08:17 mischief
    -rw-r--r--   1 mailman mailman  1305390 Apr 24 15:58 post
    -rw-r--r--   1 mailman mailman  1216641 Apr 21 12:07 qrunner
    -rw-r--r--   1 mailman mailman 32565672 Apr 25 01:18 smtp
    -rw-r--r--   1 mailman mailman 55022378 Apr 21 12:21 smtp-failure
    -rw-r--r--   1 mailman mailman 22717240 Apr 25 01:18 subscribe
    -rw-r--r--   1 mailman mailman  3882693 Apr 25 00:50 vette
  3. Israel.lopez

    Israel.lopez Member

    Mar 4, 2003
    Likes Received:
    Trophy Points:
    Hate to bring up an old thread. But I wanted to add my recent experience with this.

    To others who are having the dreaded "Bug in Mailman"

    Bug in Mailman version 2.1.11.cp3

    We're sorry, we hit a bug!

    Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.

    I was investigating the same thread of issues as the OP, and this is what i found.

    Error log for mailman not being written /usr/local/cpanel/3rdparty/mailman/logs/error
    Therefore the errors were being written to the apache error_log file, the mailman error log did not have write perms.

    When after watching the error log for mailman, and re accessed the site, I noticed this in the error log finally.
    Mar 05 20:55:50 2009 admin(14904): @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    admin(14904): [----- Mailman Version: 2.1.11.cp3 -----]
    admin(14904): [----- Traceback ------]
    admin(14904): Traceback (most recent call last):
    admin(14904):   File "/usr/local/cpanel/3rdparty/mailman/scripts/driver", line 101, in run_main
    admin(14904):     main()
    admin(14904):   File "/usr/local/cpanel/3rdparty/mailman/Mailman/Cgi/", line 71, in main
    admin(14904):     mlist = MailList.MailList(listname, lock=0)
    admin(14904):   File "/usr/local/cpanel/3rdparty/mailman/Mailman/", line 130, in __init__
    admin(14904):     self.Load()
    admin(14904):   File "/usr/local/cpanel/3rdparty/mailman/Mailman/", line 649, in Load
    admin(14904):     dict, e = self.__load(file)
    admin(14904):   File "/usr/local/cpanel/3rdparty/mailman/Mailman/", line 615, in __load
    admin(14904):     fp = open(dbfile)
    admin(14904): IOError: [Errno 13] Permission denied: '/usr/local/cpanel/3rdparty/mailman/lists/'
    admin(14904): [----- Python Information -----]
    admin(14904): sys.version     =   2.4.3 (#1, May 24 2008, 13:47:28)
    [GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]
    admin(14904): sys.executable  =   /usr/bin/python2.4
    admin(14904): sys.prefix      =   /usr
    admin(14904): sys.exec_prefix =   /usr
    admin(14904): sys.path        =   /usr
    admin(14904): sys.platform    =   linux2
    admin(14904): [----- Environment Variables -----]
    But I still havent figured out what permissions the setup should have.

    So i just chgrp -R nobody mailman ... see what that does.

    Actually... dont do that, it breaks a lot of stuff, I just ended up reinstalling mailman through the /scripts/ directory and it seemed to fix it all.
    #3 Israel.lopez, Mar 5, 2009
    Last edited: Mar 5, 2009
  4. blargman

    blargman Well-Known Member

    Sep 11, 2007
    Likes Received:
    Trophy Points:
    Israel I'm curious what your doing differently than I. I've tried reinstalling mailman and I end up with the same issues. Did you remove all your lists as well? The biggest thing I'm seeing here is these errors.

    List: problem processing
    [Errno 20] Not a directory:

    This doesn't seem right. Those mbox files are supposed to be directories?

Share This Page