Jedito

Well-Known Member
Aug 16, 2001
46
0
306
when somebody try to subscribe to the mailing list it gave an error:
&Bug in Mailman version 2.0.10

We're sorry, we hit a bug!
Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs. &

When I look at the mailmain error logs, this is what it say
&May 29 16:44:22 2002 admin(4370): @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
admin(4370): [----- Mailman Version: 2.0.10 -----]
admin(4370): [----- Traceback ------]
admin(4370): Traceback (innermost last):
admin(4370): File &/usr/local/cpanel/3rdparty/mailman/scripts/driver&, line 96, in run_main
admin(4370): main()
admin(4370): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Cgi/subscribe.py&, line 76, in main
admin(4370): process_form(mlist, doc)
admin(4370): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Cgi/subscribe.py&, line 187, in process_form
admin(4370): mlist.AddMember(email, pw, digest, remote)
admin(4370): File &/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py&, line 1005, in AddMember
admin(4370): text)
admin(4370): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Message.py&, line 211, in __init__
admin(4370): OutgoingMessage.__init__(self, text)
admin(4370): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Message.py&, line 205, in __init__
admin(4370): self['Message-ID'] = Utils.make_msgid(idstring='Mailman')
admin(4370): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Utils.py&, line 764, in make_msgid
admin(4370): idhost = socket.gethostbyaddr(socket.gethostname())[0]
admin(4370): error: host not found
admin(4370): [----- Python Information -----]
admin(4370): sys.version = 1.5.2 (#1, Jul 5 2001, 03:02:19) [GCC 2.96 20000731 (Red Hat Linux 7.1 2
admin(4370): sys.executable = /usr/bin/python
admin(4370): sys.prefix = /usr
admin(4370): sys.exec_prefix= /usr
admin(4370): sys.path = /usr
admin(4370): sys.platform = linux-i386
admin(4370): [----- Environment Variables -----]
admin(4370): DOCUMENT_ROOT: /home/username/public_html
admin(4370): SERVER_ADDR: 209.197.236.44
admin(4370): HTTP_ACCEPT_ENCODING: gzip, deflate
admin(4370): CONTENT_LENGTH: 82
admin(4370): CONTENT_TYPE: application/x-www-form-urlencoded
admin(4370): PATH_TRANSLATED: /home/username/public_html/username_domain.com
admin(4370): REMOTE_ADDR: 200.51.235.107
admin(4370): SERVER_SOFTWARE: Apache/1.3.23 (Unix) mod_gzip/1.3.19.1a mod_bwlimited/1.0 PHP/4.1.2 mod_log_bytes/0.3 FrontPage/5.0.2.2510 mod_ssl/2.8.7 Ope$
admin(4370): HTTP_ACCEPT_LANGUAGE: en-us
admin(4370): GATEWAY_INTERFACE: CGI/1.1
admin(4370): SERVER_PORT: 80
admin(4370): HTTP_CONNECTION: Keep-Alive
admin(4370): HTTP_USER_AGENT: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)
admin(4370): HTTP_ACCEPT: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword$
admin(4370): REQUEST_URI: /mailman/subscribe/username_domain.com
admin(4370): HTTP_CACHE_CONTROL: no-cache
admin(4370): QUERY_STRING:
admin(4370): SERVER_PROTOCOL: HTTP/1.1
admin(4370): PATH_INFO: /username_domain.com
admin(4370): HTTP_HOST: domain.com
admin(4370): REQUEST_METHOD: POST
admin(4370): SERVER_SIGNATURE: &ADDRESS&Apache/1.3.23 Server at www.domain.com Port 80&/ADDRESS&

admin(4370): SCRIPT_NAME: /mailman/subscribe
admin(4370): SERVER_ADMIN: [email protected]
admin(4370): SCRIPT_FILENAME: /usr/local/cpanel/3rdparty/mailman/cgi-bin/subscribe
admin(4370): PYTHONPATH: /usr/local/cpanel/3rdparty/mailman
admin(4370): HTTP_REFERER: http://domain.com/mailman/listinfo/username_domain.com
admin(4370): SERVER_NAME: www.domain.com
admin(4370): REMOTE_PORT: 3492&

I tried to upgrade python but this didn't solved the problem.
Can anybody help me here?
 

Annette

Well-Known Member
PartnerNOC
Aug 12, 2001
445
0
316
This appears to be the root of the error:

admin(4370): idhost = socket.gethostbyaddr(socket.gethostname())[0]
admin(4370): error: host not found

Is this a new machine? Is the hostname valid? What about the actual domain name that owns the list?
 

Jedito

Well-Known Member
Aug 16, 2001
46
0
306
Hi Annete
Its not a new server, neither a new account, it used to works ok, but sudelly stoped :(
 

shaun

Well-Known Member
PartnerNOC
Verifed Vendor
Nov 9, 2001
708
1
318
San Clemente, Ca
cPanel Access Level
DataCenter Provider
Twitter
i just fixed this problem for ZUI you dont happen to be at VOSN are you?

here's the fix i found. First off if your at VOSN they are going thru some changes (moving datacenters i beleive) and well their ip's on the machines are a mess. run /scripts/fixmailmanwithsuexec and make sure that the ip it returns is the true base ip of the server. If it is then good. What i did was this.

1. I moved /usr/local/cpanel/3rdparty/mailman to /usr/local/cpanel/3rdparty/mailman-old
2. Then ran /scripts/upcp (this will rebuild mailman)
3. Then you have to copy all the data out of the old mailmain folder to the new one.


If you want email me your root password and ip address and a test mailman admin url and i will fix. [email protected]
 

Jedito

Well-Known Member
Aug 16, 2001
46
0
306
Yes, its server at VOSN

I tried what you said:

1. /scripts/fixmailmanwithsuexec resolved to a IP on the server
2. I moved /usr/local/cpanel/3rdparty/mailman to /usr/local/cpanel/3rdparty/mailman-old
3. Then ran /scripts/upcp (this will rebuild mailman)
4. Moved mailmain-old/lists/ mailmain-old/data/ and mailmain-old/archives to the new mailmain folder, but I still get

[quote:34b7a0542e]
File &/usr/local/cpanel/3rdparty/mailman/scripts/driver&, line 96, in run_main
admin(10048): main()
admin(10048): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Cgi/subscribe.py&, line 76, in main
admin(10048): process_form(mlist, doc)
admin(10048): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Cgi/subscribe.py&, line 187, in process_form
admin(10048): mlist.AddMember(email, pw, digest, remote)
admin(10048): File &/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py&, line 1005, in AddMember
admin(10048): text)
admin(10048): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Message.py&, line 211, in __init__
admin(10048): OutgoingMessage.__init__(self, text)
admin(10048): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Message.py&, line 205, in __init__
admin(10048): self['Message-ID'] = Utils.make_msgid(idstring='Mailman')
admin(10048): File &/usr/local/cpanel/3rdparty/mailman/Mailman/Utils.py&, line 769, in make_msgid
admin(10048): idhost = socket.gethostbyaddr(socket.gethostname())[0]
admin(10048): error: host not found
[/quote:34b7a0542e] :(