The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mailman problems with 11.32.5.10

Discussion in 'E-mail Discussions' started by MediaServe, Oct 2, 2012.

  1. MediaServe

    MediaServe Well-Known Member
    PartnerNOC

    Joined:
    Apr 9, 2004
    Messages:
    126
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nashville, TN USA
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Anyone else having mailman issues on 11.32.5.10?

    Mailman isn't working properly on 11.32.5.10 for a few of our servers. Mail man error log says: AttributeError: 'module' object has no attribute 'AuthListPoster' and the admin interface for users reports the typical "We're sorry, we hit a bug!" error message. I'm not finding any helpful discussion of this particular error here or elsewhere.

    Nothing I've tried to correct has worked except for rolling back from current to release, and now that release is at 11.32.5.10 the problems are reoccurring on the same servers, so I'm rolling back to stable (11.32.4.15). Now I'm worried that once stable hits 11.32.5.10 I'll be in real trouble.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,807
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please attempt to reinstall Mailman using the following command:

    Code:
    # /usr/local/cpanel/bin/mailman-install --force
    I did find another report with a similar error message to the one you reported. It was caused by the following file being set to immutable:

    Code:
    /usr/local/cpanel/3rdparty/mailman/Mailman/Defaults.py
    You may want to check that as well if the forced Mailman install fails to resolve the issue.

    Thank you.
     
  3. MediaServe

    MediaServe Well-Known Member
    PartnerNOC

    Joined:
    Apr 9, 2004
    Messages:
    126
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nashville, TN USA
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Thanks, I think you've helped me identify the issue. cPanel's Mailman Defaults.py doesn't, (or at least didn't previously), include the personalization option, and we require our clients to use unsubscription links. We had modified Defaults.py and set it immutable, before writing a postupcp script to keep the file updated with the personalization option while allowing it to be updated by cPanel updates also. Probably just missed the chattr -i commands on a couple servers.

    Thanks!
     
Loading...

Share This Page