The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mailman/Qrunner 100% cpu

Discussion in 'E-mail Discussions' started by cPanelNick, Jul 27, 2003.

  1. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    If anyone is still having a problem with qrunner taking up 100% of the cpu, please put in a support ticket and post the number here. thanks!

    cPanel.net Support Ticket Number:
     
  2. techark

    techark Well-Known Member

    Joined:
    May 22, 2002
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    Still going on here on at least 10 servers.

    PID USER PRI NI SIZE RSS SHARE STAT %CPU %MEM TIME COMMAND
    14854 mailman 17 0 6588 6576 1996 R 98.0 0.6 1085m python2

    cPanel.net Support Ticket Number: 19380
     
  3. chrisbond

    chrisbond Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hereford, United Kingdom
    Still happening here
    Still happening here: Ticket 19155

    cPanel.net Support Ticket Number: 19155
     
  4. acetate

    acetate Active Member

    Joined:
    Aug 16, 2001
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Same here... Ticket #19436
    Running /scripts/fixmailman works but only till the next nightly updates.

    Thanks.

    cPanel.net Support Ticket Number:
     
    #4 acetate, Jul 28, 2003
    Last edited: Jul 28, 2003
  5. essentials

    essentials Member

    Joined:
    Mar 25, 2002
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ticket 19425

    Thanks.

    cPanel.net Support Ticket Number:
     
  6. rghigliazza

    rghigliazza Member
    PartnerNOC

    Joined:
    Aug 19, 2001
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    same problem

    Same problem with mailman, mailnull and qrunner

    cPanel.net Support Ticket Number: 19454
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This problem is caused by any of the following:

    1) /etc/hosts is broken (has wrong hostname)
    2) Anytime a domain that has a mailman list cannot be resolved (dns)
    3) Anytime a domain that has a mailman list that is on the server but not in /etc/localdomains



    The following should bypass problems 2/3 (it will not fix the dns or setup problems for the domain, but it will prevent mailman from using up the cpu when there is a configuration problem)

    /scripts/exim4
    wget -O /etc/exim.conf \
    http://host.cpanel.net/~nick/mailman-fixups/exim.conf
    /usr/local/cpanel/3rdparty/mailman/bin/mailmanctl -s stop
    rm -f /usr/local/cpanel/3rdparty/mailman/qfiles/out/*
    /usr/local/cpanel/3rdparty/mailman/bin/mailmanctl -s start
    /etc/rc.d/init.d/exim restart
    rm -f /usr/local/cpanel/3rdparty/mailman/qfiles/out/*
    sleep 5
    rm -f /usr/local/cpanel/3rdparty/mailman/qfiles/out/*

    cPanel.net Support Ticket Number:
     
  8. chrisbond

    chrisbond Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hereford, United Kingdom
    Not sure if this is related but i did /scripts/exim4 then checked /var/log/exim_mainlog and mail wasnt working:

    2003-07-29 16:02:14 abandon queue run (load 3.78, max 3.00)
    2003-07-29 16:02:14 End queue run: pid=8938
    2003-07-29 16:02:19 exim 4.20 daemon started: pid=9058, -q1h, listening for SMTP on port 25 (IPv4)
    2003-07-29 16:02:19 Start queue run: pid=9065
    2003-07-29 16:02:19 exim 4.20 daemon started: pid=9066, -q1h, not listening for SMTP
    2003-07-29 16:02:19 exim 4.20 daemon started: pid=9071, no queue runs, listening for SMTP on port 465 (IPv4)
    2003-07-29 16:02:19 Start queue run: pid=9067
    2003-07-29 16:02:19 abandon queue run (load 3.48, max 3.00)
    2003-07-29 16:02:19 End queue run: pid=9067
    2003-07-29 16:02:19 End queue run: pid=9065
    2003-07-29 16:03:24 19hW0Z-0002Qf-SU Failed to create spool file /var/spool/exim_incoming/input//19hW0Z-0002Qf-SU-D: Permission denied
    2003-07-29 16:03:31 19hW0h-0002Qw-G2 Failed to create spool file /var/spool/exim_incoming/input//19hW0h-0002Qw-G2-D: Permission denied
    2003-07-29 16:03:33 19hW0j-0002R6-3B Failed to create spool file /var/spool/exim_incoming/input//19hW0j-0002R6-3B-D: Permission denied


    Had to edit /scripts/exim4 and comment the mailscanner line out then i could apply the fixes here, only time will tell whether it has worked or not.

    cPanel.net Support Ticket Number:
     
  9. chrisbond

    chrisbond Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hereford, United Kingdom
    Further to that fix did not work followed instructions to the tee (apart from the one line comment in /scripts/exim4).

    PID USER PRI NI SIZE RSS SHARE STAT %CPU %MEM TIME COMMAND
    14503 mailman 15 0 4824 4776 1932 R 98.6 0.4 13:24 python2

    cPanel.net Support Ticket Number:
     
  10. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    You'll need to change /etc/exim.conf to /usr/local/etc/exim/configure under freebsd

    cPanel.net Support Ticket Number:
     
  11. chrisbond

    chrisbond Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hereford, United Kingdom
    Im on redhat 8 =)

    cPanel.net Support Ticket Number:
     
  12. chrisbond

    chrisbond Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hereford, United Kingdom
    When we likey to have a fix on this its causing high loads on our servers now....

    cPanel.net Support Ticket Number:
     
  13. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This should be resolved in the latest edge build.

    /Nick

    cPanel.net Support Ticket Number:
     
  14. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Nick we are running build R108 do we need to run anything to fix this problem for this release?

    cPanel.net Support Ticket Number:
     
  15. bluedog

    bluedog Member

    Joined:
    Aug 20, 2002
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    What about people not running latest edge? I am on latest stable and this started happening? Unbelievable started getting 1000 emails in the queue. Had over 3000 in the queue in the span of an hour. Running the mailman fix now tried stopping all exim instances but that didn't work either.

    cPanel.net Support Ticket Number:
     
  16. H2Hosting.com

    H2Hosting.com Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    something is strange with mailman on one of my server

    /usr/local/cpanel/3rdparty/mailman/bin/mailmanctl -s stop

    bash: /usr/local/cpanel/3rdparty/mailman/bin/mailmanctl: No such file or directory

    root@ [/var/log]# ls -l /usr/local/cpanel/3rdparty/mailman/bin/
    total 152
    drwxrwsr-x 2 mailman mailman 4096 Aug 1 21:52 ./
    drwxrwsr-x 19 mailman mailman 4096 Dec 2 2001 ../
    -rwxr-xr-x 1 mailman mailman 6620 Aug 1 21:52 add_members*
    -rwxr-xr-x 1 mailman mailman 3838 Aug 1 21:52 arch*
    -rwxr-xr-x 1 mailman mailman 2462 Aug 1 21:52 check_db*
    -rwxr-xr-x 1 mailman mailman 8964 Aug 1 21:52 check_perms*
    -rwxr-xr-x 1 mailman mailman 7123 Aug 1 21:52 clone_member*
    -rwxr-xr-x 1 mailman mailman 8090 Aug 1 21:52 config_list*
    -rwxr-xr-x 1 mailman mailman 4474 Aug 1 21:52 digest_arch*
    -rwxr-xr-x 1 mailman mailman 1282 Aug 1 21:52 dumpdb*
    -rwxr-xr-x 1 mailman mailman 4915 Aug 1 21:52 find_member*
    -rwxr-xr-x 1 mailman mailman 2957 Aug 1 21:52 list_lists*
    -rwxr-xr-x 1 mailman mailman 3519 Aug 1 21:52 list_members*
    -rwxr-xr-x 1 mailman mailman 2386 Aug 1 21:52 mmsitepass*
    -rwxr-xr-x 1 mailman mailman 2440 Aug 1 21:52 move_list*
    -rwxr-xr-x 1 mailman mailman 6983 Aug 1 21:52 newlist*
    -rw-r--r-- 1 mailman mailman 1552 Aug 1 21:52 paths.py
    -rw-r--r-- 1 mailman mailman 276 Aug 1 21:52 paths.pyc
    -rwxr-xr-x 1 mailman mailman 3051 Aug 1 21:52 remove_members*
    -rwxr-xr-x 1 mailman mailman 2952 Aug 1 21:52 rmlist*
    -rwxr-xr-x 1 mailman mailman 8234 Aug 1 21:52 sync_members*
    -rwxr-xr-x 1 mailman mailman 12809 Aug 1 21:52 update*
    -rwxr-xr-x 1 mailman mailman 925 Aug 1 21:52 version*
    -rwxr-xr-x 1 mailman mailman 6245 Aug 1 21:52 withlist*


    ... and when I am trying to connect to admin interface, conenction timed out and I see following in ps -ef:

    nobody 5251 29391 0 22:38 ? 00:00:00 /usr/bin/python -S /usr/local/cpanel/3rdparty/mailman/scripts/driver admindb

    Why /usr/bin/python? Should be /usr/bin/python2 :rolleyes:
     
    #16 H2Hosting.com, Aug 1, 2003
    Last edited: Aug 1, 2003
  17. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Same problem with mailman eating up all kinds of server load...but the script fixed it.
    WHM 7.4.0 cPanel 7.4.0-E4
    RedHat 7.3 - WHM X v2.1

    cPanel.net Support Ticket Number:
     
  18. H2Hosting.com

    H2Hosting.com Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    I like this comment... One of domain was removed from the server, but mailing list files were not removed and still here /usr/local/cpanel/3rdparty/mailman/lists/

    cPanel.net Support Ticket Number:
     
  19. getnetworks

    getnetworks Member

    Joined:
    Jun 24, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Just had this happen on one of our servers running v7.4.2 R158. We keep trying to kill the process but it just comes right back.

    Anyone have any ideas? This server hasn't had any account additions/deletions in about a month.

    cPanel.net Support Ticket Number:
     
  20. marius

    marius Well-Known Member
    PartnerNOC

    Joined:
    Jun 10, 2002
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bucharest
Loading...

Share This Page