Mailman subscription confirmation via email stopped working in version 80

brianc

Well-Known Member
May 16, 2003
178
4
168
When you join a mailman mailing list, mailman will send out a subscription confirmation email to confirm your subscription to the mailman list. You can either confirm via a web page or email. Confirmation via the webpage works fine. The way confirmation by email works is the subscriber responds to the confirmation email by replying to it via their email program. However this does not work. The replies to the confirmation email are being sent to the default mail account on the server instead of to the Mailman list:

2019-06-03 18:46:11 1hXviV-0004Ly-Ka => valid_user <listname_d[email protected]domain-list.net> R=localuser T=dovecot_delivery_no_batch C="250 2.0.0 <[email protected]> 6HfHKDOj9VxvQQAA5VZP6A Saved"

I believe this is due to some new change you implemented for + addressing in the v80? It was working prior to v80. Whatever you did broke list subscription confirmations via email.

I have filed a support ticket:
12482233
 
Last edited:

brianc

Well-Known Member
May 16, 2003
178
4
168
It has nothing to do with my post.

Who the heck changed my topic heading??? It misrepresents the problem I have discovered.
 
Last edited by a moderator:

brianc

Well-Known Member
May 16, 2003
178
4
168
I did. This title had little meaning:
'New Mailman Bug Introduced?'
Well little meaning is better then misleading meaning. I said this:

"The confirmation emails are being sent to the default mail account on the server:"

That is pretty clear. It has nothing to do with a link in the body of the confirmation message. In fact, I clearly stated that the link to the confirmation web page is working. I am pretty sure this is a new bug and serious one at that so my topic heading was spot on.

Now can I get some assistance with this?
 

brianc

Well-Known Member
May 16, 2003
178
4
168
The subject line is changed again however it is inaccurate but that is my fault. I did not accurately explain the problem so I will edit my original post.

The confirmation email is sent to the subscriber. That works. The problem is when the subscriber tries to confirm their subscription by REPLYING to the confirmation email, the reply is sent to the default mail account of the account that the list belongs to INSTEAD of being sent to Mailman so the reply can be processed by it.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,910
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello Brian,

Thank you for sharing the ticket number. I'm monitoring ticket 12482233 and will update this thread with the outcome once it's closed.

Thank you.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,910
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello Brian,

To update, it looks like the issue was isolated to the custom "VERP_CONFIRMATIONS = Yes" setting in the /usr/local/cpanel/3rdparty/mailman/Mailman/mm_cfg.py file, which is not natively supported in the Exim build provided with cPanel & WHM. Can you confirm if that sums up the cause of the issue?

Thank you.