The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mailman Upgrade? When?

Discussion in 'E-mail Discussions' started by Ashocka, Jul 5, 2008.

  1. Ashocka

    Ashocka Member

    Joined:
    Aug 22, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    As I understand it CPanel's version of Mailman is 2.1.9cp2. Can I ask why CPanel has not upgraded to the most recent version 2.1.11 (2008-06-07)

    version 2.1.10 was released (2008-04-21)

    Is anyone at CPanel following these upgrades... and where do you post update announcements on the website?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,466
    Likes Received:
    196
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. Ashocka

    Ashocka Member

    Joined:
    Aug 22, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,466
    Likes Received:
    196
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Sorry, you asked:

    Those links are where you can follow updates.
     
  5. Ashocka

    Ashocka Member

    Joined:
    Aug 22, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Okay, thanks, but what I was more looking for was a concise listing of all the packages within CPanel and their current version. In this case CPanel is lagging well behind. Why?
     
  6. Ashocka

    Ashocka Member

    Joined:
    Aug 22, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    It's amazing one pays for a product like this and such a simple and reasonable request goes unanswered.
     
  7. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    We are currently working on setting up such a thing. If you need to know about any specific version of any software we bundle with cPanel, simply email sales@cpanel.net with your inquiry and we'll be able to provide you with the most up-to-date information until we can get this new web page up and running :).
     
  8. Ashocka

    Ashocka Member

    Joined:
    Aug 22, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply and clarification
     
  9. brianc

    brianc Well-Known Member

    Joined:
    May 16, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    When is upgrading forthcoming?

    I noticed the original question was never answered:

    When can we expect an upgrade of mailman within cPanel?

    Thanks!
     
  10. Ashocka

    Ashocka Member

    Joined:
    Aug 22, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Yes, exactly. It just amazes me in this day and age of information that you cannot get a simple answer to a question that must have some project status somewhere in CPanel. Sometimes these things just astound me.
     
  11. handsonhosting

    handsonhosting Well-Known Member

    Joined:
    Feb 17, 2002
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Omaha, NE
    cPanel Access Level:
    Root Administrator
    Just adding to this thread that a MailMan update is urgently needed.

    PCI Compliance companies are now failing the PCI Scan as the Mailman version in the latest cPanel is exploitable to under the heading of "Mailman Multiple Input Validation Vulnerabilities".

    Vulnerability Mailman Multiple Input Validation Vulnerabilities
    Port 443/tcp
    Scan Date 28-AUG-2008 03:27
    URL
    Protocol https Port 443 Read Timeout 10000 Method GET Demo
    Path /mailman/admin/mailman
     
  12. misterMan

    misterMan Registered

    Joined:
    Apr 12, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    PCI Compliance

    Need mailman 2.1.10 for PCI compliance, and while we're at it openSSL HAS to get to past 0.9.8b. This is imperative.

    PS I've read all the other forums on Open SSL, ...not much there. Unless someone has info I haven't seen.

    Thanks for any info!
     
  13. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
  14. mambovince

    mambovince Well-Known Member

    Joined:
    Jan 15, 2005
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    London, UK
    I've seen recent discussions that hosts have been phasing out mailman because hardly anyone uses it and it consumes a considerable amount of resources when enabled.

    Any server experts confirm this?

    Thanks

    - Vince
     
  15. brianc

    brianc Well-Known Member

    Joined:
    May 16, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    That is not true for us. Mailman is a very important part of our service offering. We also do not throttle our smtp servers either as seems to be the typical trend these days. We do a simple screening of any mailman list to get a feel of what their list volume is doing and then put them on the appropriate server.

    We host hundreds of mailing lists along with standard web/email hosting services and with some simple configuration tweaks, our server load has been no problem at all.
     
  16. slim

    slim Well-Known Member

    Joined:
    May 27, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    I have been advised that the openSSL problems that PCI scans pick up are actually false positives. Apparently Rethat have back ported the patch code into the 0.9.8b version thats installed by cpanel and therefore our servers are not venerable to the openSSL issues reported by the scan.
    The mailman issue however is seperate and I would appriciate it if cpanel guys could fix this.
     
  17. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
  18. slim

    slim Well-Known Member

    Joined:
    May 27, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
  19. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I know the developers and QA Team is working on that issue. However, I do not have an ETA on when an updated Mailman will be pushed out.
     
  20. brianc

    brianc Well-Known Member

    Joined:
    May 16, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Just received this from cPanel:

    ------- Comment #1 from kenp@cpanel.net 2008-09-18 16:31 -------
    Published 2.1.11 in EDGE and CURRENT 11.23.6. Other branches coming soon. Thank
    you for the report.


    YEAH!!!!!!
     
Loading...

Share This Page