The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mailman upgrade

Discussion in 'E-mail Discussions' started by casey, Jun 5, 2003.

?

Would you like to see Mailman upgraded?

  1. Yes

    59 vote(s)
    89.4%
  2. No

    0 vote(s)
    0.0%
  3. I don't care

    7 vote(s)
    10.6%
  1. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    None of my customers speak English. Therefore, the current version of mailman is simply useless to me. How many people would love to see mailman upgraded? I know I would. I don't care whether it's the latest, only one that supports multiple languages.
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    *bump* :)

    cPanel.net Support Ticket Number:
     
  3. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    :)

    cPanel.net Support Ticket Number:
     
  4. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator
    I'd like to see all the software upgraded.... Exim, etc.

    I understand not having the latest cutting edge versions since it takes time to work out bugs, but perhaps a 6 month lag would be good.

    I feel like we are working on Win98 :(

    cPanel.net Support Ticket Number:
     
  5. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    I would particularly like for mailman to be upgraded, because it is the last item on my control panel that lacks language integration. The majority of my customers want mailing lists, but they cannot read English well enough to use the current version of mailman.

    cPanel.net Support Ticket Number:
     
  6. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    The biggest reason to upgrade MailMan would be for no other reason but to close the security VULNNNNNNNNNNNNNNNNNNNNN oops my N key got stuck, we reported yesterday, in the forums and in a TT. I see nothing has been done about it as usual. With security VULNS of this sort we should expect priority fixes and not "WELL GET TO IT SOMETIME". We pay alot of money and DarkOrb gets their money from us every month on time, evertime. Then why should i expect any less service?

    cPanel.net Support Ticket Number:
     
  7. MN-Robert

    MN-Robert Well-Known Member

    Joined:
    Feb 19, 2003
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Yes it needs to be upgraded, or replaced with something else

    cPanel.net Support Ticket Number:
     
  8. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    If it does get replaced with something else, PLEASE let it be one that has multilingual capabilities.

    cPanel.net Support Ticket Number:
     
  9. MN-Robert

    MN-Robert Well-Known Member

    Joined:
    Feb 19, 2003
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    We have alot of complaints with mailman. Something else would be better imho

    cPanel.net Support Ticket Number:
     
  10. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    I see Nick is on the boards right now. Nick, do you have plans to upgrade mailman for those of us with international customers?:) :)

    cPanel.net Support Ticket Number:
     
  11. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    The latest mailman only support python2. Thus only redhat8 and above can support it by default. We do plan on having 8.0 or later boxes upgraded to the newer mailman, but there are still lots of bugs in 2.1.2 that need to be worked around.

    cPanel.net Support Ticket Number:
     
  12. MN-Robert

    MN-Robert Well-Known Member

    Joined:
    Feb 19, 2003
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    What about another solution nick?

    cPanel.net Support Ticket Number:
     
  13. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    My hero. :)

    cPanel.net Support Ticket Number:
     
  14. MN-Robert

    MN-Robert Well-Known Member

    Joined:
    Feb 19, 2003
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Im assuming most poeple are running 7.3 that's all as 8 never really proved itself.

    cPanel.net Support Ticket Number:
     
  15. dhabets

    dhabets Well-Known Member

    Joined:
    Dec 31, 2001
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    DataCenter Provider
    you can install python2 alongside python 1.5.x on RH 7.3...

    cPanel.net Support Ticket Number:
     
  16. pirania1

    pirania1 Well-Known Member

    Joined:
    May 10, 2003
    Messages:
    126
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami, FL
    Yeah. I upgraded python on my machine when I tried updating mailman manually, but it didn't worked (with mailman).
    I still have new python with old mailman and it works fine.
    So I guess not RH version will be criteria here, but python version.

    cPanel.net Support Ticket Number:
     
  17. k3of4

    k3of4 Registered

    Joined:
    Jan 13, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I agree we need an upgraded mailman. I posted this 6 months ago or so. I am very frustrated with it.

    Mailman integration with cpanel now is even still a bit buggy, I would mind a bit of semi-equal bugginess and a lot more flexibility of Mailman 2.

    cPanel.net Support Ticket Number:
     
  18. bonkoif

    bonkoif Registered

    Joined:
    Jun 16, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I understand the python2 requirement for the new Mailman, however it is available for both RedHat 7.2 and 7.3 (we use it here at work on 7.2, and I use Mailman 2.1 on another RedHat 7.3 system). And those are official RedHat RPMs included in the distro.

    Here are the links (through RPMfind):
    RedHat 7.2 - python2-2.1.1-3.72.i386.rpm
    RedHat 7.3 - python2-2.2.2-11.7.3.i386.html

    Given that Python2 is available and works for RedHat 7.2 and 7.3, can we please see an upgrade to Mailman 2.1? There are all sorts of wonderful new features!

    -Todd

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  19. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator
    an idea....

    what if the current release is cleaned up a little bit, and made 'Final' for older servers.

    Then, move to the next level with new software.

    example: cpanel 6.5 is Final, for older servers with older software : prior to RH 7.2 maybe, or some other old software that might be holding back progress.

    Then, cpanel 7.0 starts production, utilizing the latest software upgrades. Exim 4, Mailman 2, etc.

    This gives legacy servers a platform, that you can still support for a little bit. And it allows those ready to move on to better, more secure and stable servers the option to move Forward.

    Time to let go of the old. Once a software upgrade is out for 6 months, some serious thought should be given into supporting it. (Exim 4, Mailman 2, etc.)

    :)

    If I need to get a new server to utilize the most up-to-date, secure cpanel software, I will.

    cPanel.net Support Ticket Number:
     
  20. OneSizeFitsAll

    OneSizeFitsAll Well-Known Member

    Joined:
    Dec 19, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
Loading...

Share This Page