The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mailque buildup

Discussion in 'E-mail Discussions' started by vagus, Apr 29, 2004.

  1. vagus

    vagus Registered

    Joined:
    Apr 20, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    HI,

    I've always been running Cpanel on my servers, but in the last few versions of update, (3 months or so), I've been getting a mailque buildup.

    I try and deliver all messages, yet every single mail gets a connection refused message.

    Anyone had any problems with this?

    Anyone got a solution?
     
  2. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    They are probably invalid emial addresses and therefor just sit in your queue and cannot be delivered so delete them.
     
  3. vagus

    vagus Registered

    Joined:
    Apr 20, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    that's half the problem.

    I have used half of the que to send out so verified emails?
     
  4. wipl_piyush

    wipl_piyush Well-Known Member

    Joined:
    Oct 31, 2003
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY
    Hello Vagus,

    If you having a problem of mails getting collected in you mail queue and not getting delivered from option from WHM then you can put a cron which will continously deliver the mails from the que.

    exim -qff -v -C /etc/exim_outgoing.conf &
     
  5. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    When I try to run exim -qff -v -C /etc/exim_outgoing.conf &

    I get bash: exim command not found.. Do I have to run this from a particular place??
     
  6. wipl_piyush

    wipl_piyush Well-Known Member

    Joined:
    Oct 31, 2003
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY
    Check wheather you got the file /etc/exim_outgoing.conf or not...it seems thatu using older version of exim ...as it works fine on exim 4
     
  7. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    This should only be used if you have mailscanner installed, otherwise use this

    exim -qff -v &

    This is will start to force the mail delivery, however it will also start to fill your screen with all messages. If you want to just force the queue and not see those tons of messages, just use this:

    exim -qff &
     
  8. vagus

    vagus Registered

    Joined:
    Apr 20, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Thanks for these guys.

    It's still coming up with connection refused or faild on all mail sending tho, so Maybe this is an MX problem.

    I'll take a look at that, then see if there's anything I can do.

    Thanks alot guys
     
  9. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    np. :)

    What you can do is take one domain and on shell try to dig its MX.

    dig MX domain.com

    This will atleast tell you if the domain has a valid MX entry or not. If incase the domain has no valid MX it would be safe to just delete all those mails from the mailq.
     
  10. cortecds

    cortecds Member

    Joined:
    Jan 15, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    This is great, but why?

    Hi,
    I did run this: exim -qff &
    And I think it is working.

    But, why do emails going to other servers still just sit in my queue for even up to 21 days?
    Shouldn't my server just delete them after so many days?

    Isn't this done in the Exim Configuration Editor?
    Isn't this suppose fix it:
    timeout_frozen_after = 2d

    I wish cpanel spoke english.

    Thanks for your help!
     
  11. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    is this command "exim -qff &" same as the one in WHM for sending all mails in mailqueue?
     
  12. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
    Can someone enlighten me? What's with the exim -qff option (i.e. two f's)?

    What's wrong with just exim -qf?

    from http://www.exim.org/exim-html-2.00/doc/html/spec_5.html ...

    -qf option

    This option operates like `-q', and may appear with or without a following time. The difference is that a delivery attempt is forced for each message, and any frozen messages are automatically thawed, whereas with `-q' only those non-frozen addresses that have passed their retry times are tried.
     
  13. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  14. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16

Share This Page