Mails don't reach our servers if sent to more than X recipients

Operating System & Version
CloudLinux v7.9.0
cPanel & WHM Version
v100.0.4

sevenokve

Member
Aug 11, 2020
9
2
3
Puerto La Cruz, Venezuela
cPanel Access Level
Root Administrator
Hi there!

Recently I realized (because a client complained) that if anyone tried to send an email to any of the accounts in our sever and in the email there were more than X recipients, the email wouldn't reach our server.

The thing is that as soon as the server "sees" that there are more than X recipients the connection seems to get dropped. I figured this out because the message doesn't even show in our exim logs.

Do you have any idea of why this may be happening?

FYI in the "Exim Configuration Manager" these options are set to "No rejection based on number of recipients":

Maximum message recipients (soft limit) (Minimum: 1; Maximum: 100) [?]
  • No rejection based on number of recipients
Maximum message recipients before disconnect (hard limit) (Minimum: 1; Maximum: 100) [?]
  • No disconnection based on number of recipients
 

sevenokve

Member
Aug 11, 2020
9
2
3
Puerto La Cruz, Venezuela
cPanel Access Level
Root Administrator
Great.

Just to give you some more information, I tried sending from both a Microsoft and a Google account. In each message sending to more than 20 email accounts hosted in our server. In both cases connection seems to get dropped since there is nothing in the server logs about those messages.

Also if it's useful, I've tried with 2 different servers of ours and the behavior is exactly the same.
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
1,045
112
118
Houston, TX
cPanel Access Level
Root Administrator
Great.

Just to give you some more information, I tried sending from both a Microsoft and a Google account. In each message sending to more than 20 email accounts hosted in our server. In both cases connection seems to get dropped since there is nothing in the server logs about those messages.

Also if it's useful, I've tried with 2 different servers of ours and the behavior is exactly the same.
could you check the /var/log/exim_rejectlog per Finn's suggestion?
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
1,045
112
118
Houston, TX
cPanel Access Level
Root Administrator
I just checked in both servers and in neither of them there is information related to those messages. :/
Would you be able to open a ticket using the link in my signature and provide me with the ID? Otherwise, your web hosting provider should be able to open one for you.