The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MailScanner and Cron mail

Discussion in 'E-mail Discussions' started by denisdekat09, May 5, 2004.

  1. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Hello,

    I am noticing that my cron mail that goes to root is not working...

    Check this out:
    Funny, I use to get these all the time. Anyone experiencing something similar?

    Thanks for any tips...
     
  2. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    I do not know why I post stuff here, hardly ever does anyone answer :(

    In any case, I found more problems here, it seems that my server is having trouble sending mail to any user at my server name. How nice :)



    I see this all over my sever, it cannot mail locally:

    2004-05-05 10:29:00 1BLNOO-0006Kd-Hh <= real_user@server00.server.net U=ebarrelr P=local S=617
    2004-05-05 10:29:00 1BLNOO-0006Kd-Hh == real_user@server00.server.net R=defer_router defer (-1): All deliveries are handled by MailScanner
    2004-05-05 10:29:00 1BLNOO-0006Kd-Hh ** real_user@server00.server.net: retry timeout exceeded
    2004-05-05 10:29:00 1BLNOO-0006Ki-RM <= <> R=1BLNOO-0006Kd-Hh U=mailnull P=local S=1579
    2004-05-05 10:29:00 1BLNOO-0006Ki-RM == real_user@server00.server.net R=defer_router defer (-1): All deliveries are handled by MailScanner
    2004-05-05 10:29:00 1BLNOO-0006Ki-RM ** real_user@server00.server.net: retry timeout exceeded
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, you've only left it an hour between posts :rolleyes:

    Anyway:
    Have you checked that MailScanner is running?
    Have you restarted MailScanner?

    If they don't work, try monitoring both the exim mainlog and the maillog and then send an email:
    tail -f /var/log/exim_mainlog
    tail -f /var/log/maillog

    Does MailScanner start processing shortly after an email arrives, according to both logs?
     
  4. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Thanks for the reply, Last couple of posts went unanswered ;) I was feeling down about the forum...

    I will check this, thanks for the tip. I looked in /var/log/exim_mainlog, with the live tail option and all, the problem is it works except when it runs from the cron jobs, very strange.

    I ended up finding this:
    http://forums.cpanel.net/showthread.php?s=&threadid=17493&highlight=cron+exim

    Whic is my problem, and it seems to have returned for more than just me. I am going to update exim and try the stuff you tried and see if that helps. I also tried the edits that post set and that seemed ot help folks...

    Thanks for your response :)
     
  5. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
Loading...

Share This Page