The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MailScanner not delivering mail

Discussion in 'E-mail Discussions' started by mauinet, Nov 5, 2007.

  1. mauinet

    mauinet Active Member

    Joined:
    Mar 2, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Maui
    I am using MailScanner v 2.60. Mail is not being delivered to the local users. The mail queue is now over 10,000 emails. The message log shows the error:
    MailScanner: Process did not exit cleanly, returned 255 with signal 0
    over and over. I reinstalled MailScanner and clamav but no help. I ran /scripts/upcp also but still no email delivered. What can I look for next??

    I'm running CentOS 4.5 and WHM 11.11.0

    Thanks,
    TR
     
    #1 mauinet, Nov 5, 2007
    Last edited: Nov 5, 2007
  2. mauinet

    mauinet Active Member

    Joined:
    Mar 2, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Maui
    How to uninstall MailScanner

    As I can't get MailScanner to deliver mail I would like to uninstall it. We have over 14,000 emails in the queue now. I found the FAQ on uninstall but it doesn't say whether the emails already in the queue will still be delivered after the uninstall. Does anyone know if MailScanner can be uninstalled without loosing the queue??

    Thanks,
    TR
     
  3. u-hosts

    u-hosts Member

    Joined:
    Dec 7, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    what does tail -f /var/log/maillog says?

    did you install MailScanner(msinstall) from configserv? If not try that best, easy and free solutions and workis great!
     
  4. tangowebs

    tangowebs Well-Known Member

    Joined:
    Oct 12, 2004
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0
    Im getting this error:

    Nov 21 03:38:31 server4 MailScanner[31215]: WARNING: You are trying to use the SpamAssassin cache but your DBI and/or DBD::SQLite Perl modules are not properly installed!
    Nov 21 03:38:31 server4 MailScanner[31215]: ClamAV Perl module not found, did you install it?
    Nov 21 03:38:35 server4 MailScanner[31216]: MailScanner E-Mail Virus Scanner version 4.65.3 starting...
    Nov 21 03:38:36 server4 MailScanner[31216]: SpamAssassin temporary working directory is /var/spool/MailScanner/incoming/SpamAssassin-Temp
    Nov 21 03:38:36 server4 MailScanner[31216]: WARNING: You are trying to use the SpamAssassin cache but your DBI and/or DBD::SQLite Perl modules are not properly installed!
    Nov 21 03:38:36 server4 MailScanner[31216]: ClamAV Perl module not found, did you install it?
     
  5. MaraBlue

    MaraBlue Well-Known Member

    Joined:
    May 3, 2005
    Messages:
    335
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Carmichael, CA
    cPanel Access Level:
    Root Administrator
    Where I would start is to install the needed Perl mods. You didn't say what version of Perl you're running...if it's anything less than 5.8.8 I'd upgrade Perl first, then install/reinstall the Perl mos you need.
     
Loading...

Share This Page