The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MailScanner not getting messages?

Discussion in 'E-mail Discussions' started by dory36, May 12, 2004.

  1. dory36

    dory36 Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    A problem perhaps related to MailScanner update... (I'm on the most recent release, and on the stable exim release.)

    I'd sure appreciate help with this, if anyone has ideas where to look!

    A user (not root) cron job that sends output via emai every 5 minutes continues to run, but the mail started failing at 3:05 yesterday. (It LOOKs like all the rest of the email is getting delivered, as far as I can tell.)

    There was no human interaction happening on the server anywhere near that time, fwiw, and nothing else happening then as far as I know.

    It looks to my untrained eye that the cron email fails, then an error email about that failure fails also.

    Relevant log entry from exim_mainlog:

    2004-05-12 03:15:01 1BNotJ-0007fA-6r <= [useraddress] U=[userid] P=local S=884
    2004-05-12 03:15:01 1BNotJ-0007fA-6r == cron@domain.com R=defer_router defer (-1): All deliveries are handled by MailScanner
    2004-05-12 03:15:01 1BNotJ-0007fA-6r ** cron@domain.com: retry timeout exceeded
    2004-05-12 03:15:01 1BNotJ-0007hN-Ey <= <> R=1BNotJ-0007fA-6r U=mailnull P=local S=1752
    2004-05-12 03:15:01 1BNotJ-0007hN-Ey == [useraddress] R=defer_router defer (-1): All deliveries are handled by MailScanner
    2004-05-12 03:15:01 1BNotJ-0007hN-Ey ** [useraddress]: retry timeout exceeded
    2004-05-12 03:15:01 1BNotJ-0007hN-Ey [useraddress]: error ignored
    2004-05-12 03:15:01 1BNotJ-0007hN-Ey Completed
    2004-05-12 03:15:01 1BNotJ-0007fA-6r Completed

    This sequence repeats every time the cron job runs.

    fwiw, these two messages never arrive in the mailbox, and there is NO entry in the mailscanner log for these two messages, nor any others within a couple of minutes on either side of the 3:15am time of the message.

    Any suggestions?

    Thanks - Bill
     
    #1 dory36, May 12, 2004
    Last edited: May 12, 2004
  2. dory36

    dory36 Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    update: I added queue_only_override = false to exim.conf and things started working agin.
     
Loading...

Share This Page