The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MailScanner not getting server email

Discussion in 'E-mail Discussions' started by Devil Inside, Dec 4, 2003.

  1. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    this isn't constant but it just stopped me from getting the logwatch email.

    root@dh2.doorhost.net
    All deliveries are handled by MailScanner

    ------ This is a copy of the message, including all the headers. ------
    ------ The body of the message is 196351 characters long; only the first
    ------ 106496 or so are included here.

    Return-path: <root@dh2.doorhost.net>
    Received: from root by dh2.doorhost.net with local (Exim 4.24)
    id 1ARqJ8-0000Vc-8B
    for root@dh2.doorhost.net; Thu, 04 Dec 2003 04:02:02 -0600
    To: root@dh2.doorhost.net
    Subject: LogWatch for dh2.doorhost.net
    Message-Id: <E1ARqJ8-0000Vc-8B@dh2.doorhost.net>
    From: root <root@dh2.doorhost.net>
    Date: Thu, 04 Dec 2003 04:02:02 -0600


    what do I do?
     
  2. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    I am seeing this too. As with yours it is not constant and sometimes goes through ok. Also all other mail is working fine with no issues other than root emails. We are running the mailscanner from layer1. Anybody have any ideas on what is going on and how to fix this?
     
  3. Bima

    Bima Member

    Joined:
    Jan 2, 2002
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Do the rellevant entries in /var/log/exim_mainlog look like that:
    Marek
     
  4. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
  5. Bima

    Bima Member

    Joined:
    Jan 2, 2002
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I had a similar problem. It looks like Exim does not acknowledge deferred deliveries by MailScanner and after the retry time is up, it starts failing messages.
    The problem was solved after I set up a cron job that regularly cleans Exim's retry database. Here is the command I addedd to /etc/crontab
    I hope it will work for you.

    Marek
     
  6. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    Yes they look exactly like that and is just emails coming from server root that are messing up. Also sometimes they work perfect and sometime they do that.
     
  7. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    Hmmm I could have swore I already had the commands that would clean out the exim database (all 3 lines) but when I looked they were not there. Guess I forgot to add them in on this server for some reason. :eek: I went ahead and added them in (also ran them manually to go ahead and get them in the system) and will see just what happens.
     
  8. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    ok - thank you!

    I'll see if this helps it. :)
     
Loading...

Share This Page