The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MailScanner Question

Discussion in 'E-mail Discussions' started by bmcpanel, Jul 3, 2006.

  1. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    I recently downloaded and installed the free mailscanner version. The instructions were clear and concise. Thanks to them for that.

    Anyway, during the install, it was suggested to NOT use :blackhole: and instead to use :fail:. Apparently, using :fail: will avoid exim from processing the message and will save resources. I'm up for that. Here is what the site says....

    Using :fail: the email is never accepted into the server. During the initial SMTP negotiation when the senders SMTP server connects to your SMTP server, the sending SMTP server issues a RCPT command notifying your server which email address the email to follow is intended for. Your server then checks whether the recipient email actually exists on your server (a POP3 account, an alias or a catchall alias) and if it does not, it issues an SMTP DENY which terminates the attempt to deliver the email.
    This saves bandwidth as the email data is never received into your server
    This saves server resources as the email never has to be processed
    This complies with the SMTP RFC's because the sending SMTP server receives the DENY command
    Your server does not send a bounce message (just the DENY command) <<<<<
    Your server does not send anything to the sender of the email (i.e. the address in the From: line)
    The sending SMTP server is responsible for notifying the original sender


    To sum up, it says Using :fail: the email is never accepted into the server.. However, since I reset all accounts to use :fail:, I now have hundreds of bounce emails sitting in my queue, apparaently awaiting delivery back to the FROM address. So, using :fail: effectively is filling up my email queue.... (See example below)

    Is this intended behavior of using :fail:?

    1FxXMA-0006LN-N6-D
    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    franklin@ns.myserver.net
    (generated from info@blahblah.com)
    retry timeout exceeded

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <PeterParsons@geologist.com>
    Received: from [210.159.xxx.xxx] (port=63691 helo=SOTEC-NHBS29JVK)
    by ns.xxxxxxxx.net with esmtp (Exim 4.52)
    id 1FxXMA-0006LE-CX
    for info@xxxxxxxx.com; Mon, 03 Jul 2006 18:57:30 -0400
    Message-ID: <06890581023962.080B54EF3D@TXXKPC>
    From: "Peter" <PeterReyes@registerednurses.com>
    To: <info@xxxxxxxxxxxx.com>
    Subject: Just published Now you have chance to do it Feel Pleasure from
    Date: Tue, 4 Jul 2006 07:56:40 +0900
    MIME-Version: 1.0
    X-Mailer: Microsoft Office Outlook, Build 11.0.5510
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
    Thread-Index: gkmsP0F0TmVU4RIKZ3jI7zzmNsAtEUO7nG3E
    Content-Type: text/plain;
    charset="Windows-1252"
    Content-Transfer-Encoding: 7bit

    Hello to you!
    You gape for shooting like you had seen in those films…

    Be realistic – you always wanted it

    Worried it won't work?

    You may find what you need here: http://www.basszass.com
    Just check yourself!
     
  2. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    This is probably just a nasty coincidence... :fail: *can't* fill your queue. Something else is going on.
     
  3. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    I have verified that when I send an email to an non-existent email address on the server, FROM and address that is undeliverable (so the bounced message stays in the queue), a bounce message is generated and placed in the queue. I am certain of this.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Shouldn't happen as :fail: should stop the email getting on the server in the first place. What are the full transaction lines for a message ID in your exim_mainlog when you send in a message that behaves like that?
     
  5. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    Also, let's step back for a moment... how did you configure :fail: on all accounts? It sounds like it's not configured to :fail: actually
     
  6. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    How Configured? :fail:

    Actually, I used the line from the MailScanner site in regard to changing multiple default settings on emails to :fail:

    [root] replace :blackhole: :fail: -- /etc/valiases/*
     
  7. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    This is odd... but I have been testing this again and now, I am getting the pop-up error message in my mail program when attempting to send an email to a non-existant email address, which I assume is Exim sending back the SMTP DENY message. Since the message did not send, it is also not in the queue, which is the expected behavior.

    I am certain this did not happen before. Before, the test message sent to a non-existant email address was accepted by the server and went into the queue. Yes, the account was set to :fail: before hand.

    Strange. Possibly, I have made an error somewhere in my interpretation of the events earlier, but I am certain I did not receive the SMTP DENY message in my mail program earlier (I use Thunderbird).

    I will continue to monitor this.
     
Loading...

Share This Page