The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MailScanner WHM Status Page No Longer update

Discussion in 'cPanel Developers' started by demomen, Aug 29, 2005.

  1. demomen

    demomen Well-Known Member

    Joined:
    Sep 25, 2004
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Hi

    After a reboot the MailWatch does not show any recent emails it is stuck on the time when rebooted. WHM - mailwatch/status.php It is the first time this occured after reboots, all mail is running normally and mailscanner is to

    Anyone know what to do to fix the status
     
  2. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Did you check to make sure MailScanner is running?
     
  3. demomen

    demomen Well-Known Member

    Joined:
    Sep 25, 2004
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Yeah it was running, I restarted MailScanner, reloaded and the same for exim. It just seemed to start working a few hours later without touching anything. Would be useful to know how to fix this immediately if it occurs again though

    Thanks for the reply
     
  4. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    /scripts/buildeximconf
    /scripts/mailscannerupdate
    service exim restart
     
  5. Alterego

    Alterego Member

    Joined:
    Mar 20, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    MailWatch is stuck since yesterday...

    I'm still looking for a solution to this problem myself. It happened a week ago or more and I could not get it to restart. It 'refreshes' to the same static place in time. Last week, re-installing MailScanner and ClamAV did the trick. Tried it this time, to no avail. Also the above scripts had no effect. Any help would be good. Mailscanner is working, but mailwatch is not updating. I think it is having a problem with the database, as this error seems to indicate from the maillog:

    Sep 20 10:04:41 area51 MailScanner[6484]: ClamAV Module ERROR:: Could not load databases from /usr/local/share/clamav

    I thought it has something to do with permissions, perhaps, but I don't think so, now. Any thoughts?
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I've just noticed Mailwatch is dead this morning. Last email thru was right around when I ran the mail directory conversion yesterday.

    Anyone have an idea how to get it going again?
     
  7. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks for that. That fixed it. And thanks to chirpy as well.
     
Loading...

Share This Page