The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Main Domain / Accounts and SSL redirect

Discussion in 'General Discussion' started by ovolatier, May 4, 2013.

  1. ovolatier

    ovolatier Member

    Joined:
    May 4, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I have a issue, I would like to be able to install a website on my own domain :www.mydomain.com

    My nameservers are : ns01.mydomain.com and ns02.mydomain.com

    My server name is: s002.mydomain.com

    I have a certificate SSL multi domain on godaddy, install for both

    In my Manage Service SSL Certificates in WHM I have install the certificate s002.mydomain.com (on all services) but show up as mydomain.com (certainly because is a SSL multi domain)

    When I try to connect to www.mydomain.com, I can see my Site but when I try to connect in https://www.mydomain.com I cannot see my site. My server forward it on the default website page of the cpanel

    Can you tell my what is wrong, why can I not able to use my main domain in SSL for a website ?

    Thanks
    Oli
     
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Does mydomain.com have a dedicated IP?
     
  3. ovolatier

    ovolatier Member

    Joined:
    May 4, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Both mydomain.com and s002.mydomain.com has a dedicated IP

    s002.mydomain.com is on a share IP of the server
    mydomain.com has his own IP

    FYI, I saw something else: I can see my website on www.mydomain.com but not on mydomain.com, weird
     
  4. ovolatier

    ovolatier Member

    Joined:
    May 4, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
  5. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    When you installed the certificate for your hostname you used user "nobody", and when you installed the certificate for mydomain.com you used the username of the mydomain.com acount?
     
  6. ovolatier

    ovolatier Member

    Joined:
    May 4, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    yes exactly

    But before my SSL Service was on mydomain.com,

    I changed everything but my server act like nothing changed
     
  7. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Well if it was my server I would probably remove the certificates and then reinstall them.
     
  8. ovolatier

    ovolatier Member

    Joined:
    May 4, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Impressive !!

    This is working well now

    Thank you
    Oli
     
  9. fonsaiyuk

    fonsaiyuk Registered

    Joined:
    May 5, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    yes , I think will changed
     
Loading...

Share This Page