The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Main Email Filling Up?

Discussion in 'E-mail Discussions' started by carlaron, Oct 5, 2003.

  1. carlaron

    carlaron Well-Known Member

    Joined:
    Jun 26, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Is there any way to turn off the "main" POP account for a domain? Or forward it to :blackhole:?

    This account is invariable an email account that never gets checked by anyone, and so it fills up with junk, causing a disk quota message eventually.

    I have redirected the default to "backhole", and even tried forwarding the main address to blackhole, but it still gets in there.

    The mail that is piling up in there seems to be bounces and other warnings, from the system, that seems to circumvent the forwarder to blackhole...

    cPanel.net Support Ticket Number:
     
  2. eskwire

    eskwire Member

    Joined:
    Sep 10, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Have you tried logging into cpanel in the domain that you want to turn off the default mail address. Once you are logged in go to mail and then to Default address and then to Set Default Address.

    At this screen you can use this hint:

    You can enter :blackhole: to discard all incoming unrouted mail or :fail: no such address here to bounce it.


    I currently use :fail: no such address here for a few of my domains. This works better in a few cases beacause if someone mistypes the email address then it bounces back and they do not blame the mail server for "loosing the mail"

    Hope this helps
     
  3. carlaron

    carlaron Well-Known Member

    Joined:
    Jun 26, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    As I mentioned in the original post, I tried both :blackhole: and :fail:no such recipient.

    The problem is that the bounces filling up the mailbox are not addressed to an undefined recipient.

    They are real bounces, directed to the main account.

    They seem to be bounces of bounces... When SPAM comes in addressed to an undefined address, the system bounced it back to them. Most of the time the sender is fake, so that bounce bounces back...

    What I needed is not a way to send undefined email into the blackhole (I have that), but a way to send all mail addressed to the default user to the blackhole.

    I believe I have found a solution by putting a .forward file in the home directory that redirects to /dev/null
     
  4. NeutralGold

    NeutralGold Well-Known Member

    Joined:
    Jun 5, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Yes I was about to tell you to point it to /dev/null, good work.
     
  5. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Does the .forward need to be in /home/mail or just /home ?

    Thanks
     
  6. carlaron

    carlaron Well-Known Member

    Joined:
    Jun 26, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Actually, it needs to be in /home/mainusername/, where "mainusername" is of course the username of the main account for the domain.
     
  7. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Is there a way to accomplish this via cpanel?

    I don't want to delete the main account mail... instead, I want to forward it to the customer's ISP.

    Example:

    username: xyz
    domain: xyz.com

    Main account is then xyz@xyz.com

    The customer doesn't want to pop off my server, he just wants ALL mail for @xyz.com, including xyz@xyz.com, to be forwarded to his ISP account (xyz@aol.com)

    I can send all unrouted mail for his domain EASILY to xyz@aol.com, but what about mail that is purposely sent to xyz@xyz.com... how can I forward this mail to xyz@aol.com? And how do I prevent his mailbox from filling up? (assuming the forward is also going to save a message in the mailbox)

    Yikes, this seems like such a simple task, and I can accomplish so easily using other vendor's control panels. I love cPanel so far, but this is one thing that drives me and my customers nuts. They don't want to use POP mail on my server, they want all mail to be forwarded to their ISP account. How to do this in cpanel??

    Thanks!

    - Scott
     
  8. carlaron

    carlaron Well-Known Member

    Joined:
    Jun 26, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    To forward mail to their ISP email account, in most cases, I think it is best to use a specific Forwarder in cpanel to forward each person's address, then have the undefined ones (default address) go to blackhole or bounce back.

    If you forward any and everything, you wind up forwarding a lot of spam, addressed to usernames that are just randomly generated by spammers.

    The only address that is not easy to forward in cPanel is the "main" account address. In my opinion, this should not even count as an email address, but since every user in a unix system has a mailbox, you can't just eliminate it. But you can use the good old fashioned .forward file for any regular unix account.

    To follow your example: Use cPanel's FileManager to create a text file in the /home/xyz directory (home directory of the main user "xyz"). The file should be named ".forward" (note the period at the beginning of the name.)

    Whatever email address(es) you list in that file will get copies of any mail sent to xyz@xyz.com.

    If you just want the mail to dispappear, then put in /dev/null instead of any email addresses.
     
  9. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I agree with you about the Default address, that's fine.

    Either way, the main question I have is how to use cPanel so that the Main Account is forwarded to another ISP e-mail address and to NOT collect on the server.

    If your .forward idea works (forwards yet does not collect mail) then that will work for now. Maybe someday Nick will make it easier for customers to manage their main account (i.e. make it possible to do this via cPanel instead of having the customer bug me to set it up)

    Thanks man, I'll give the .forward a try!

    - Scott
     
  10. myusername

    myusername Well-Known Member
    PartnerNOC

    Joined:
    Mar 6, 2003
    Messages:
    691
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    chown -R us.*yourbase*
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I have the same issue with email bounceing the default address forever, thus filling the mail queue in a seemingly endless loop. Quite annoying and my /var partition is constantly filling to 100% capacity.

    Have you tried simply typing /dev/null into the :blackhole: box to see if that works?
     
  11. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I thought :blackhole: = /dev/null ?
     
  12. royhobbs

    royhobbs Member

    Joined:
    Apr 30, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Utah
    Do you have an example of the .forward file?

    Thanks!
     
  13. carlaron

    carlaron Well-Known Member

    Joined:
    Jun 26, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Sort of... Setting :blackhole: for the default address discards any mail going to an undefined address at the domain. But, if mail is addressed to the main user of a domain, it is not undefined.

    And since the main user seems to act as a sort of postmaster for the domain (you'll see the main user listed in the return path header for any mail delivered to any user in the domain), the main user gets any number of administrative emails and all of the bounces.

    Adding this .forward file, containing /dev/null pretty much disables the main email account, but since none of my clients actually ever checks it, that is OK with me.
     
  14. carlaron

    carlaron Well-Known Member

    Joined:
    Jun 26, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    make a file named ".forward" (without the quotes, but with the period) in the domain's home directory (i.e. /home/theuser/)

    In that file, type "/dev/null" (without the quotes)
     
Loading...

Share This Page