Maintenance ended; however, it did not exit cleanly (256). The following events were logged: “scripts/rpmup”.

oscarhcaballero

Registered
Nov 20, 2021
2
0
1
Spain
cPanel Access Level
Root Administrator
Hi, my cPanel version is 11.100.0.4

I have this issues during the updating process and I need to solve it before updating my Centos 8 to AlmaLinux.


This is what I get when I execute rpmup command. Thanks for your help!


Bash:
[[email protected] ~]# /usr/local/cpanel/scripts/rpmup

checkyum version 22.3  (excludes: bind-chroot kernel)

Last metadata expiration check: 0:52:30 ago on Sat Nov 20 11:58:41 2021.

Error:

Problem 1: package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed

  - cannot install both alt-php-internal-common-7.4.21-3.el8.x86_64 and alt-php-internal-common-7.4.16-1.el8.x86_64

  - cannot install the best update candidate for package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64

  - cannot install the best update candidate for package alt-php-internal-common-7.4.16-1.el8.x86_64

Problem 2: package libstdc++-devel-8.5.0-4.el8_5.alma.x86_64 requires libstdc++(x86-64) = 8.5.0-4.el8_5.alma, but none of the providers can be installed

  - cannot install both libstdc++-8.5.0-4.el8_5.alma.x86_64 and libstdc++-8.5.0-4.el8_5.x86_64

  - cannot install the best update candidate for package libstdc++-devel-8.4.1-1.el8.x86_64

  - cannot install the best update candidate for package libstdc++-8.4.1-1.el8.x86_64

Problem 3: libgcc-8.5.0-4.el8_5.alma.i686 has inferior architecture

  - package gcc-8.5.0-4.el8_5.alma.x86_64 requires libgcc >= 8.5.0-4.el8_5.alma, but none of the providers can be installed

  - cannot install both libgcc-8.5.0-4.el8_5.alma.x86_64 and libgcc-8.5.0-4.el8_5.x86_64

  - cannot install the best update candidate for package libgcc-8.4.1-1.el8.x86_64

  - cannot install the best update candidate for package gcc-8.4.1-1.el8.x86_64

Problem 4: libgomp-8.5.0-4.el8_5.alma.i686 has inferior architecture

  - package gcc-8.5.0-4.el8_5.alma.x86_64 requires libgomp = 8.5.0-4.el8_5.alma, but none of the providers can be installed

  - cannot install both libgomp-8.5.0-4.el8_5.alma.x86_64 and libgomp-8.5.0-4.el8_5.x86_64

  - package gcc-c++-8.5.0-4.el8_5.alma.x86_64 requires gcc = 8.5.0-4.el8_5.alma, but none of the providers can be installed

  - cannot install the best update candidate for package libgomp-8.4.1-1.el8.x86_64

  - cannot install the best update candidate for package gcc-c++-8.4.1-1.el8.x86_64

Problem 5: problem with installed package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64

  - package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed

  - package alt-php-internal-common-7.4.16-1.el8.x86_64 requires alt-php-internal = 7.4.16-1.el8, but none of the providers can be installed

  - cannot install both alt-php-internal-7.4.21-3.el8.x86_64 and alt-php-internal-7.4.16-1.el8.x86_64

  - cannot install the best update candidate for package alt-php-internal-7.4.16-1.el8.x86_64

(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

(XID 6cnxw9) “/usr/bin/yum” reported error code “1” when it ended:

checkyum version 22.3  (excludes: bind-chroot)
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
583
54
103
Houston, TX
cPanel Access Level
Root Administrator

oscarhcaballero

Registered
Nov 20, 2021
2
0
1
Spain
cPanel Access Level
Root Administrator
Thanks for your answer. I have followed the steps for disabling imunify360, as the articles explain and this are now the errors that I get.


[[email protected] ~]# yum update
Last metadata expiration check: 0:00:11 ago on Mon 22 Nov 2021 12:12:02 AM CET.
Error:
Problem 1: cannot install both glibc-devel-2.28-164.el8.x86_64 and glibc-devel-2.28-151.el8.x86_64
- package glibc-static-2.28-151.el8.x86_64 requires glibc-devel = 2.28-151.el8, but none of the providers can be installed
- cannot install the best update candidate for package glibc-devel-2.28-151.el8.x86_64
- problem with installed package glibc-static-2.28-151.el8.x86_64
Problem 2: cannot install both jasper-libs-2.0.14-5.el8.x86_64 and jasper-libs-2.0.14-4.el8.x86_64
- package jasper-devel-2.0.14-4.el8.x86_64 requires jasper-libs(x86-64) = 2.0.14-4.el8, but none of the providers can be installed
- cannot install the best update candidate for package jasper-libs-2.0.14-4.el8.x86_64
- problem with installed package jasper-devel-2.0.14-4.el8.x86_64
Problem 3: package libstdc++-devel-8.5.0-4.el8_5.alma.x86_64 requires libstdc++(x86-64) = 8.5.0-4.el8_5.alma, but none of the providers can be installed
- cannot install both libstdc++-8.5.0-4.el8_5.alma.x86_64 and libstdc++-8.5.0-4.el8_5.x86_64
- cannot install the best update candidate for package libstdc++-devel-8.4.1-1.el8.x86_64
- cannot install the best update candidate for package libstdc++-8.4.1-1.el8.x86_64
Problem 4: cannot install both libxcrypt-devel-4.1.1-6.el8.x86_64 and libxcrypt-devel-4.1.1-4.el8.x86_64
- package libxcrypt-static-4.1.1-4.el8.x86_64 requires libxcrypt-devel(x86-64) = 4.1.1-4.el8, but none of the providers can be installed
- cannot install the best update candidate for package libxcrypt-devel-4.1.1-4.el8.x86_64
- problem with installed package libxcrypt-static-4.1.1-4.el8.x86_64
Problem 5: libgcc-8.5.0-4.el8_5.alma.i686 has inferior architecture
- package gcc-8.5.0-4.el8_5.alma.x86_64 requires libgcc >= 8.5.0-4.el8_5.alma, but none of the providers can be installed
- cannot install both libgcc-8.5.0-4.el8_5.alma.x86_64 and libgcc-8.5.0-4.el8_5.x86_64
- cannot install the best update candidate for package libgcc-8.4.1-1.el8.x86_64
- cannot install the best update candidate for package gcc-8.4.1-1.el8.x86_64
Problem 6: libgomp-8.5.0-4.el8_5.alma.i686 has inferior architecture
- package gcc-8.5.0-4.el8_5.alma.x86_64 requires libgomp = 8.5.0-4.el8_5.alma, but none of the providers can be installed
- cannot install both libgomp-8.5.0-4.el8_5.alma.x86_64 and libgomp-8.5.0-4.el8_5.x86_64
- package gcc-c++-8.5.0-4.el8_5.alma.x86_64 requires gcc = 8.5.0-4.el8_5.alma, but none of the providers can be installed
- cannot install the best update candidate for package libgomp-8.4.1-1.el8.x86_64
- cannot install the best update candidate for package gcc-c++-8.4.1-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)