The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

major email problem...please help its urgent

Discussion in 'E-mail Discussions' started by I Love Jesus, Dec 16, 2004.

  1. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    I have a domain on the server that has at least 20 "default address" setup.

    Default Address (in mail area) says:

    Default Address Maintenance
    All unrouted mail will be sent to:

    There is only the main account user1@the domain.com setup, but about 20 default addresses in the "default address" area. Client says that any email such as anything@thedomain.com should be forwarded to the main account user1@thedomain.com (because it is setup in the default address area). So, if someone sends an email to whatever1@thedomain.com (even though that whatever1 email does not exist) it should forward to the default address user1@thedomain.com (what he considers default address woks like a "catch all"). Is this true? He says it worked all along until last night (been a customer for a few months).

    Some examples of the default address (what he says works as catch all accounts) are:

    user2@domain2.com (not on server) should forward to user2@thdomain.com
    user3@domain2.com (not on server) should forward to user3@thedomain.com

    Now, keep in mind the only account created is user1@thedomain.com.

    What I did:
    /scripts/exim4 -latest
    /scripts/buildeximconf
    /scripts/updatenow
    /scripts/restartsrv_exim

    Cpanel 9.9.9R-14.
    Fedora Core 2

    Please help
     
    #1 I Love Jesus, Dec 16, 2004
    Last edited: Dec 16, 2004
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Did you have a look to see its all configured correctly in the users cpanel ? What about /etc/valiases/domain.com ? Any wierdness happening in the exim logs ?
     
  3. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    /etc/valiases/thedomain.com shows...

    email1@domain.net: user1@domain.net
    email2@domain.net: |/home/user1/fwd.sh email2@domain2.net
    email3@domain.net: |/home/user1/fwd.sh email3@domain2.net
    email4@domain.net: |/home/user1/fwd.sh email4@yahoo.com
    email5@domain.net: |/home/user1/fwd.sh email5@domain2.net
    email6@domain.net: |/home/user1/fwd.sh email6@domain2.net
    email7@domain.net: |/home/user1/fwd.sh email7@yahoo.com
    *: user1

    Note: email# = email account

    /var/log/exim_mainlog shows at least 30 completed (did not notice any incompletes). I checked the time I was speaking to him and the ones regarding that were not working do show as completed.

    Also, he checked hi spam folder, nothing there (I checked also in webmail as he did webmail also).
     
  4. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    anyone can help? sorry to bump its just an urgent thing (yes not for you but me lol).

    I hope someone can hint me here.
     
  5. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    I was able to duplicate this error myself, on the same server of course.
    I set a default address to send to a legitimate account and then did a test email send to cc@mydomain.com (account does not exist). Looks like there is a problem in cpanel itself.

    Your message cannot be delivered to the following recipients:

    Recipient address: cc@mydomain.com
    Reason: Remote SMTP server has rejected address
    Diagnostic code: smtp;550-"The recipient cannot be verified. Please check all recipients of this message to verify they are valid."
    Remote system: dns;mydomain.com (TCP|167.206.5.72|28964|xx.x.166.223|25) (server.mydomain.com ESMTP Exim 4.43 #1 Thu, 16 Dec 2004 20:02:53 -0500 )
     
  6. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Can someone please help? Anyone able to duplicate this or have an answer?
     
  7. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Many data centers offer training on how to run a dedicated server. I really think you're in over your head here. That's nothing to be ashamed about; we all have to start somewhere, but it would save you a lot of stress if you signed up for a class or training somewhere. Just a little friendly advice. You're welcome to ignore it if you like.
     
  8. picoyak

    picoyak Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    All I can say is that your valiases doesn't look right. Addresses should be colon-separated.

    should be...
    abc@localdomain: 123@otherdomain

    Personally I don't know where the pipe came from (|/home/user1/fwd.sh). Could it be a ticket or webmail system playing with that somehow? Or something else? This is what you'll have to determine.
     
Loading...

Share This Page