The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Major exim problems after update WHM/CP to the newest version

Discussion in 'General Discussion' started by Seven77, Oct 10, 2003.

  1. Seven77

    Seven77 Active Member

    Joined:
    Nov 7, 2001
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    After updating a server to the newest version WHM/CP 8.4.0S92 exim has a major problem to send emails from the server to somewhere. This problem is only with forms (php and/or cgi) and as well as with Webmail (Horde).

    You after pushing a submit button you get this error message:

    invalid value for message_size_limit: absolute value of integer "50M" is too large (overflow)

    After scanning almost every file for message_size_limit, there is no such limit......

    Mails sending and delivering through an port eg. 25 works fine. As i said, just webmail, php and cgi has this problem.

    Does anybody knows about it?

    Thanks for any help.

    Yours,
    Seven

    cPanel.net Support Ticket Number:
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This is probably in your php.ini

    cPanel.net Support Ticket Number:
     
  3. salman

    salman Member
    PartnerNOC

    Joined:
    Dec 5, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    That's an exim directive which can be set in your exim.conf file under /etc.

    50M is the internal default.

    However, changing it to any value is not fixing the problem; 0 == unlimited.

    I've already tried various settings: 10m, 1024, 2048, 10M, etc but everything results in an error message of 'value too large (overflow)'.

    Edit: I don't believe that has anything to do with php (but I'll test it out) as just issuing an exim -t command or trying to send a test email via sendmail results in the same error.

    I thought it might be perl related as the message_size value is checked in the exim perl script.. but updating perl to 581 didn't do anything productive either.
     
    #3 salman, Oct 10, 2003
    Last edited: Oct 10, 2003
  4. salman

    salman Member
    PartnerNOC

    Joined:
    Dec 5, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Welp, whatever the problem is appears to be with the cpanel install of exim.

    I compiled exim4.24 by hand on the machine which was giving problems and it looks to have fixed the issue... hopefully this doesn't raise any CPanel compatibility issues.

    cPanel.net Support Ticket Number:
     
    #4 salman, Oct 10, 2003
    Last edited: Oct 10, 2003
  5. mgebert

    mgebert Registered

    Joined:
    Nov 17, 2001
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    impossible to get exim work properly with the new config files from stable tree, neither the self-compiled version nor the cpanel-installed version works. don't know if there a more people out there having this problems.

    using an alternate config file (of the distribution), exim/sendmail -t works without any error messages. I'm making use of that to temporarily work around this problem. This might help somebody else:

    the exim binary and config files installed by cpanel will work to listen on SMTP, do smtp auth, deliver mails locally and remotely (as long as they come in over SMTP), but exim/sendmail is unable to accept mails from STDIN, and therefore anything using exim/sendmail (i.e. horde) will fail when trying to send mails.

    this is my workaround (tested on redhat 7.3/8.0:

    - keep cpanel exim and let it do the stuff mentioned above
    - get the exim source. you'll find a configure.default in the src subdir. you can copy that one to your /etc/ dir and name it exim2.conf for example. edit the file and comment out every router except dnslookup. add "self = send", to let the "second" exim send mails to cpanel exim running on port 25. dont forget to add no_local_from_check and probably the TLS lines.
    - create the Makefile for exim (read the exim manual). Make sure you include OpenSSL in case you are using TLS. Perl is not necessary. Change the path to the configuration file you've just created. once you have Makefile do a make in the source root (not a make install, or you will overwrite the cpanel exim installation).
    - rename the exim binary (in the build-xxxxx subdir) to exim2 and copy it to /usr/sbin. go there and chmod 4755 exim2 (to give it the setuid flag)
    - delete the symbolic link sendmail (still in /usr/sbin) and create a new one: ln -s exim2 sendmail

    sendmail -t should now work again. once nick provides a solution to this problem (which seems to be a configuration problem in my opinion), deleting /etc/exim2.conf , /usr/sbin/exim2 , /usr/sbin/sendmail and recreating the sendmail link pointing to exim will make everything "normal" again.

    To Nick: do have any clue where this errors could come from? a fix quite soon would be very appreciated. Do you need access to an affected machine?
     
    #5 mgebert, Oct 10, 2003
    Last edited: Oct 10, 2003
Loading...

Share This Page