The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Major Problem..

Discussion in 'General Discussion' started by acer2k, Jun 17, 2003.

  1. acer2k

    acer2k Well-Known Member

    Joined:
    Nov 12, 2001
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    I am having a problem with apache on all servers. When ever anyone uses any php script to upload a file, it is automatically CHMOD'ed 600, and is inaccessible from the web. E.g. when someone trys to upload an avatar with phpBB. Also, when they try to use an autoinstaller to install a php script, it gives them Internal Server Error when they try to access the php script. I have to run fixsuexeccgiscripts to fix the permissions on the files to make them accessible. WTF is wrong?

    cPanel.net Support Ticket Number:
     
  2. carlgm

    carlgm Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England, UK
    Do you use PHPsuexec?

    cPanel.net Support Ticket Number:
     
  3. Faldran

    Faldran Well-Known Member

    Joined:
    May 28, 2002
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    I bet he does...

    That is one script that does not upload files with correct permissions, there was one other I found that uploaded it with the wrong permissions also ( some date script ).

    But over all, most scripts upload them correctly. Like many Galleries have no problems and other similar scripts...

    I believe it has to do with the uploading script, since some scripts upload fine with 644 and others like phpBB upload with 600

    It is just that php+suexec, will no longer allow 600 mod files to be viewed.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page