make: *** [sapi/cgi/php-cgi] Error 1 on apache update

quicklyweb

Member
Apr 24, 2005
15
0
151
Today i was trying to upgrade PHP4.x to 5.2.3 so i couldn't be bothered to use/scripts/easyapache so i did it trough whm

and had following

./configure [@php-5.2.3]...(--prefix=/usr --with-xml --with-mm --enable-bcmath --enable-calendar --with-curl --with-dom --with-dom-xslt --with-dom-exslt --enable-exif --with-swf=/usr/local/flash --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --with-imap=/usr/local/imap-2004g --enable-mbstring --enable-mbstr-enc-trans --enable-mbregex --with-mcrypt --with-mhash --enable-magic-quotes --with-mm --with-mysqli --with-mysql=/usr --with-snmp --enable-ucd-snmp-hack --with-openssl --enable-discard-path --with-pear --with-pgsql=/usr --with-pspell --enable-xslt --with-xslt-sablot --enable-safe-mode --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --enable-versioning --enable-wddx --with-xmlrpc --with-zip --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
make [@php-5.2.3]...(-j 1 clean).... . Done
make [@php-5.2.3]...(-j 1).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
make: *** [sapi/cgi/php-cgi] Error 1
make [@php-5.2.3]...(install).... . . . . . . . . . . . . . . Done
make: *** [sapi/cgi/php-cgi] Error 1
initfpsuexec: using apache 1.x support
PHP version file has been updated to 4.4.7
./build all
./build install
initfpsuexec: using apache 1.x support



Apache seems to run fine but php documents are not recognised
So i assume PHP did not compile properly

But i am not sure what todo now.
 

quicklyweb

Member
Apr 24, 2005
15
0
151
i tried everything but couldm't get system to upgrade PHP 5.2.3. EVerytime i will have to use easy apache to recompile php 4.4.7

where am i going wrong?
 

sabarishks

Active Member
Jun 29, 2007
35
0
56
Hello

Hi ,

check mysql version . php5 does not support less than 4.1.22