The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"make" won't execute while installing FFMEG

Discussion in 'General Discussion' started by pauloray, Jan 27, 2012.

  1. pauloray

    pauloray Well-Known Member

    Joined:
    Jan 16, 2012
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Philippines
    cPanel Access Level:
    Root Administrator
    Hi,
    I use this guide in trying to install FFMEG, /http://servertune.com/kbase/?View=entry&EntryID=133

    I have was not able to complete this cause i got error and here's my questions:

    1. The first step says :
    "First, make sure the following binary packages are installed on your server:
    gcc, gcc4, gcc4-c++, gcc4-gfortran, gd, gd-devel, gmake, ImageMagick, ImageMagick-devel, libcpp, libgcc, libstdc++, make, ncurses, ncurses-devel, ruby, subversion"

    How can I install some of these binary packages since I do not have all these in my server? I tried "yum install libcpp" but it will say

    "No Package libcpp available. Nothing to do"

    2. I just continue following the steps and when I reached the step to run "make" command, it just says
    "make: *** No targets specified and no makefile found. Stop."


    I noticed that when I run "./configure" command, the line says:

    configure: error: ffmpeg headers not found. Make sure ffmpeg is compiled as shar ed libraries using the --enable-shared option

    Maybe this error causes "make" not to run properly.

    How can I fix this?

    Hope someone can give suggestions and please give detailed info since I am a newbie in Linux. :)

    THanks in advance.
     
    #1 pauloray, Jan 27, 2012
    Last edited: Jan 27, 2012
  2. pauloray

    pauloray Well-Known Member

    Joined:
    Jan 16, 2012
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Philippines
    cPanel Access Level:
    Root Administrator
    I am so happy I was able to make this work. After long hours searching on the net. So, here's what I did.

    1. I followed the instructions on this link:
    /http://servertune.com/kbase/?View=entry&EntryID=133 ServerTune KnowledgeTune / HowTo :: Install and configure FFmpeg and FFpeg-Php

    2. There's an error when I run ./configure saying "configure: error: ffmpeg headers not found. Make sure ffmpeg is compiled as shared libraries using the --enable-shared option"

    So, I run this command to fix it - "yum install ffmpeg-devel"

    3. Then I encountered error when "make" saying - "FFmpeg :: make: *** [ffmpeg_frame.lo] Error 1"

    I use this link to fix it - /http://servertune.com/kbase/entry/373/ ServerTune KnowledgeTune / FFmpeg :: make: *** [ffmpeg_frame.lo] Error 1

    4. Last command is "echo 'extension=ffmpeg.so' >> /usr/local/lib/php.ini"

    5. Then restart httpd (Apache)

    That's it.


    And I can see that FFMPEG is installed in my server when I go to this link

    /https://www.cebuwebsolutions.com/phpinfo.php
     
  3. hoststop

    hoststop Well-Known Member

    Joined:
    Dec 6, 2011
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bolton, UK
    cPanel Access Level:
    Root Administrator
    Easy steps to install FFMPEG /http://www.hoststop.co.uk/whmcs/knowledgebase.php?action=displayarticle&id=43 & if you receive the error refer /http://www.hoststop.co.uk/whmcs/knowledgebase.php?action=displayarticle&id=42
     
Loading...

Share This Page