The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Malformed autoresponder email

Discussion in 'E-mail Discussions' started by divemasterza, Jan 18, 2017.

  1. divemasterza

    divemasterza Member

    Joined:
    Feb 2, 2013
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    South Africa
    cPanel Access Level:
    Root Administrator
    Twitter:
    Since a couple days I am getting bounces from the emails generated by the autoresponder
    Code:
    A message that you sent contained one or more recipient addresses that were
    incorrectly constructed:
    
      CTA SmartBrief: missing or malformed local part (expected word or "<")
    
    This address has been ignored. There were no other addresses in your
    message, and so no attempt at delivery was possible.
    
    ------ This is a copy of your message, including all the headers. ------
    
    X-Autorespond: "Pokemon Go" neared $1B in 2016 revenue
    To: CTA SmartBrief
    Precedence: auto_reply
    Subject: Auto Reply: Out of office
    X-Loop: CTA SmartBrief
    It is not an isolated incident, some of my users are reporting the same issue.

    Any idea where to start on this one?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you let us know which version of cPanel is installed on this system? You can check with a command such as:

    Code:
    cat /usr/local/cpanel/version
    Additionally, could you give us an example of the "TO" field in the message header for one of the bounced message? You can replace the domain name with an example.

    Thank you.
     
  3. divemasterza

    divemasterza Member

    Joined:
    Feb 2, 2013
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    South Africa
    cPanel Access Level:
    Root Administrator
    Twitter:
    I am on the latest 11.62.04

    Code:
    Return-Path: <>
    Delivered-To: steph@xxxxxxx.co.za
    Received: from xxxxxxxx.dedicated.co.za
        by xxxxxxxx.dedicated.co.za (Dovecot) with LMTP id nPj1CmGXf1gJTAAADmXFPw
        for <steph@xxxxxxxl.co.za>; Wed, 18 Jan 2017 18:27:13 +0200
    Return-path: <>
    Envelope-to: steph@xxxxxx.co.za
    Delivery-date: Wed, 18 Jan 2017 18:27:13 +0200
    Received: from mailnull by xxxxxxxx.dedicated.co.za with local (Exim 4.88)
        id 1cTt4r-000545-Ml
        for steph@xxxxxxxl.co.za; Wed, 18 Jan 2017 18:27:13 +0200
    Auto-Submitted: auto-replied
    From: Mail Delivery System <Mailer-Daemon@xxxxxxxx.dedicated.co.za>
    To: steph@xxxxx.co.za
    Subject: Mail failure - malformed recipient address
    Message-Id: <E1cTt4r-000545-Ml@xxxxxxxxx.dedicated.co.za>
    Date: Wed, 18 Jan 2017 18:27:13 +0200
    
    A message that you sent contained one or more recipient addresses that were
    incorrectly constructed:
    
      CTA SmartBrief: missing or malformed local part (expected word or "<")
    
    This address has been ignored. There were no other addresses in your
    message, and so no attempt at delivery was possible.
    
    ------ This is a copy of your message, including all the headers. ------
    
    X-Autorespond: "Pokemon Go" neared $1B in 2016 revenue
    To: CTA SmartBrief
    Precedence: auto_reply
    Subject: Auto Reply: Out of office
    X-Loop: CTA SmartBrief
    From: "Steph Reinstein" <steph@xxxxxx.co.za>
    X-Precedence: auto_reply
    Mime-Version: 1.0
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: quoted-printable
    Message-Id: <E1cTt4r-000543-KB@xxxxxx.dedicated.co.za>
    Date: Wed, 18 Jan 2017 18:27:13 +0200
     
  4. paszczak000

    paszczak000 Active Member

    Joined:
    Nov 29, 2007
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Poland, Łódź
    The same here.

    # cat /usr/local/cpanel/version
    11.62.0.4

    It just stop working.
     
  5. divemasterza

    divemasterza Member

    Joined:
    Feb 2, 2013
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    South Africa
    cPanel Access Level:
    Root Administrator
    Twitter:
    This becomes quite an issue now... I have a couple customer complaining about this.
    I see /usr/local/cpanel/bin/autorespond has been updated 7 Jan that correspond roughly with the start of the issues
     
  6. dreamzz

    dreamzz Registered

    Joined:
    Apr 12, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    151
    I am also facing the same issue too. Anyone gotten any fix for this?
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Internal case CPANEL-10827 is open to address an issue where Autoresponder messages fail if certain characters are used in the 'from' name on the remote account. This is only affecting systems using cPanel version 62. I'll update this thread with more information on the status of this case as it becomes available.

    Thank you.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, the resolution included in cPanel version 62.0.7 with case CPANEL-10973 should address the issue reported on this thread:

    Fixed case CPANEL-10973: Autorespond: fix from line parsing.


    The full cPanel version 62 change log is located at:

    62 Change Log - Change Logs - cPanel Documentation

    Thank you.
     
Loading...

Share This Page